Linux compilation error "execv: No such file or directory"

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
已解决

Linux compilation error "execv: No such file or directory"

跳至解决方案
6,201 次查看
alexey_bezgodko
Contributor I

Hi!

I cannot compile source file with S32 Studio toolchain on Ubuntu 16.04. I get error "powerpc-eabivle-gcc: error trying to exec '/opt/NXP/S32DS_Power_v2017.R1/Cross_Tools/powerpc-eabivle-4_9/bin/../lib/gcc/powerpc-eabivle/4.9.4/../../../../powerpc-eabivle/bin/as': execv: No such file or directory".

Also the file '/opt/NXP/S32DS_Power_v2017.R1/Cross_Tools/powerpc-eabivle-4_9/bin/../lib/gcc/powerpc-eabivle/4.9.4/../../../../powerpc-eabivle/bin/as' exists but cannot be run -> during it's run error occurs "No such file or directory".

Does someone know reason?

标签 (1)
标记 (3)
0 项奖励
回复
1 解答
5,211 次查看
nxf46764
NXP Employee
NXP Employee

64Bit need 32Bit lib, so you should do as follows:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
sudo apt-get install libgtk2.0-0:i386
sudo apt-get install libxtst6:i386
sudo apt-get install gcc-multilib g++-multilib 
Hope to help you.

在原帖中查看解决方案

2 回复数
5,212 次查看
nxf46764
NXP Employee
NXP Employee

64Bit need 32Bit lib, so you should do as follows:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
sudo apt-get install libgtk2.0-0:i386
sudo apt-get install libxtst6:i386
sudo apt-get install gcc-multilib g++-multilib 
Hope to help you.
5,210 次查看
sathish_sekar
Contributor III

Hello Peng Ma,

Thanks.

In my system also below build error occurred,

arm-none-eabi-gcc: error trying to exec 'cc1': execvp: No such file or directory

now ityis  resolved.

This error occurred After installing the S32 Design studio in Ubuntu 16.04 Linux, faced the below build error

This error also resolved by

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
sudo apt-get install libgtk2.0-0:i386
sudo apt-get install libxtst6:i386
sudo apt-get install gcc-multilib g++-multilib 
0 项奖励
回复