An internal error occurred during launching a ISP graph

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

An internal error occurred during launching a ISP graph

2,052件の閲覧回数
imarkwang
Contributor I

I import a project of the ISP graph into the S32DS. And the diagram was valid. But when I emit the graph to produce code, it would complains below:

Launching ISP sources XXXXXXX encoutered a problem.

An internal error occurred during: "Launching ISP sources imx224_multiple_cameras_lut - imx224_multiple_cameras_lut".
java.lang.NullPointerException.

0 件の賞賛
4 返答(返信)

1,391件の閲覧回数
imarkwang
Contributor I

I reinstalled the S32DS and this issue never occured again.

0 件の賞賛

1,391件の閲覧回数
jiri_kral
NXP Employee
NXP Employee

Hi, 

Can you please share S32DS log file (taken after java exception occurs)? The log file is located in your workspace .metadata folder. Filename is .log. Thanks. 

Jiri

0 件の賞賛

1,391件の閲覧回数
imarkwang
Contributor I

hi,

Jiri.

The log of this error list below:


!ENTRY org.eclipse.core.jobs 4 2 2018-05-10 11:36:33.027
!MESSAGE An internal error occurred during: "Launching ISP sources imx224_multiple_cameras_lut - imx224_multiple_cameras_lut".
!STACK 0
java.lang.NullPointerException
at com.nxp.s32ds.gte.isp.core.registry.IspKernelRegistry.getKernelFileByName(IspKernelRegistry.java:120)
at com.nxp.s32ds.gte.isp.core.registry.IspKernelRegistry.resolveKernel(IspKernelRegistry.java:178)
at com.nxp.s32ds.mdt.vpt.isp.internal.ui.launch.IspGenLaunchDelegateUtil.validate(IspGenLaunchDelegateUtil.java:77)
at com.nxp.s32ds.mdt.vpt.isp.internal.ui.launch.IspGenLaunchDelegate.launch(IspGenLaunchDelegate.java:29)
at com.freescale.s32ds.cdt.debug.ui.LaunchConfigurationDelegate2Wrapper.launch(LaunchConfigurationDelegate2Wrapper.java:77)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:885)
at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:739)
at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1039)
at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1256)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

And I found that if I add a ipuv to the graph, this issue will occurred. If the ISP graph without ipuv, this issue would never occurred.

0 件の賞賛

1,391件の閲覧回数
jiri_kral
NXP Employee
NXP Employee

Hi, 

I tried reproduce your issue - but no luck. For me is adding more ipuv boxes working okay. Did you check your machine resources - like Free RAM or disk space? Can you please share your ISP Graph project? 

Jiri 

0 件の賞賛