About the compiler in Linux of S32DS

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

About the compiler in Linux of S32DS

1,618 Views
imarkwang
Contributor I

I have done some work on the S32DS in win10. But we need build some app under linux, so I tried to install the S32DS in Linux. But there are some question I am not sure yet.

I get some issue:

1.I saw three kinds of build directory for linux in the "s32v234_sdk/kernels/apu/apexcv_base_arithmetic": 

build-apu-nxp-sa-d, build-apu-tct-sa-d, build-deskwin32. 

Which build directory should be used ?

2. When I use the build-apu-nxp-sa-d to build the kernel it can work now. But using build-apu-nxp-sa-d to build the "s32v234_sdk_1.0/demos/apex/apex_add/graphs", it will always comlain that the undefined reference error to all function in ACF_Graph and ACF_Process.

 

I saw this problem the other guys had met Error compiling apexCV related function on S32 design studio for vision .

I checked the gcc version under directory  "Cross_Tools\gcc-aarch64-linux-gnu-4_9" by ./aarch64-linux-gnu-gcc -v.

It prints gcc version 4.9.3 20150413 (prerelease) (Linaro GCC 4.9-2015.05)

The gcc is default installed by the installer "S32DS_Vision_Linux_v2.0_b170913.bin"

Thanks!

 

Labels (1)
0 Kudos
1 Reply

1,010 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

the gcc version issue is related to pre-build steps. To be able build apex projects - you need to install gcc and g++ version 4.9.3 (normally by apt-get install ... ) on your OS. 

Jiri