U-boot stops when relocation starts

キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 

U-boot stops when relocation starts

ソリューションへジャンプ
643件の閲覧回数
dusanferbas
Contributor III

Hi guys,

a month ago, I raised a question about not booting from SD card. See here.

We went further and built a bootable u-boot image by playing with defconfigs, board header definitions (ls1021atwr.h) and other stuff. Now we stops when u-boot starts relocation, i.e. just between board_f and board_r init calls. I was advised to check DDR settings, but this is not the case.
Our board is based on ls1021atwr, but does not have the CPLD. So we want to remove unneeded code. Finally we found when we remove any of 3 U_BOOT_CMD definitions from ls1021atwr.c, we are unable to continue with relocation. DDR works fine, it should be something with LD script or something else. I attached logs, u-boot map and several other files for both working and not working image. Just a single change in a single file, so maps can be compared. If someone observed similar thing, please let me know.

0 件の賞賛
1 解決策
540件の閲覧回数
dusanferbas
Contributor III

As u-boot 2018 moved various CONFIG symbols from .h files into Kconfig and defconfig files, we solved this question by proper moving CONFIG symbols from ls1021atwr.h into defconfig files. There are conditional implications of symbols in Kconfigs, so we also had to remove some imply lines from these files.

Another issue was to pass make also with symbols, which are finally classified as odd ones. We skipped this test in makefile.

Thank you for your quick reply.

元の投稿で解決策を見る

0 件の賞賛
2 返答(返信)
540件の閲覧回数
Pavel
NXP TechSupport
NXP TechSupport

Usually only .h file in the /include/configs folder is needed for changing for new board.

See attached files. These files are u-boot configuration files for the LS1021a-IOT, LS1021AQDS and TWR-LS1021a boards from LSDK 19.03. The LS1021a-IOT and LS1021AQDS boards do not have CPLD.

Compare u-boot configuration file for the LS1021a-IOT and LS1021AQDS boards and configuration files for the TWR-LS1021a and your LS1021a boards.


Have a great day,
Pavel Chubakov

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 件の賞賛
541件の閲覧回数
dusanferbas
Contributor III

As u-boot 2018 moved various CONFIG symbols from .h files into Kconfig and defconfig files, we solved this question by proper moving CONFIG symbols from ls1021atwr.h into defconfig files. There are conditional implications of symbols in Kconfigs, so we also had to remove some imply lines from these files.

Another issue was to pass make also with symbols, which are finally classified as odd ones. We skipped this test in makefile.

Thank you for your quick reply.

0 件の賞賛