SDK Error while bitbake fsl-image-minimal on centos 5.9

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 

SDK Error while bitbake fsl-image-minimal on centos 5.9

2,488 次查看
phenixyan
Contributor II

[yw079@localhost build_t2080rdb-64b]$ bitbake fsl-image-minimal
Traceback (most recent call last):
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/bin/bitbake", line 31, in <module>
import bb
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/__init__.py", line 77, in <module>
from bb import fetch2 as fetch
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/fetch2/__init__.py", line 37, in <module>
import bb.persist_data, bb.utils
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/persist_data.py", line 35, in <module>
from pysqlite2 import dbapi2 as sqlite3
ImportError: No module named pysqlite2
/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/event.py:118: RuntimeWarning: Parent module 'bb' not found while handling absolute import
from bb.msg import BBLogFormatter
Error in atexit._run_exitfuncs:
Traceback (most recent call last):
File "/usr/local/lib/python2.7/atexit.py", line 24, in _run_exitfuncs
func(*targs, **kargs)
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/event.py", line 118, in print_ui_queue
from bb.msg import BBLogFormatter
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/__init__.py", line 77, in <module>
from bb import fetch2 as fetch
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/fetch2/__init__.py", line 37, in <module>
import bb.persist_data, bb.utils
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/persist_data.py", line 35, in <module>
from pysqlite2 import dbapi2 as sqlite3
ImportError: No module named pysqlite2
Error in sys.exitfunc:
Traceback (most recent call last):
File "/usr/local/lib/python2.7/atexit.py", line 24, in _run_exitfuncs
func(*targs, **kargs)
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/event.py", line 118, in print_ui_queue
from bb.msg import BBLogFormatter
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/__init__.py", line 77, in <module>
from bb import fetch2 as fetch
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/fetch2/__init__.py", line 37, in <module>
import bb.persist_data, bb.utils
File "/opt/phenix/nxp/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/persist_data.py", line 35, in <module>
from pysqlite2 import dbapi2 as sqlite3
ImportError: No module named pysqlite2
[yw079@localhost build_t2080rdb-64b]$

0 项奖励
5 回复数

622 次查看
srak
Contributor III

How to fix? I'm facing same issue. Ubuntu 20.04 on WSL.

0 项奖励

1,578 次查看
yipingwang
NXP TechSupport
NXP TechSupport

Hello Phenix Yan,

Please execute the script sources/meta-freescale/scripts/host-prepare.sh to setup the necessary host environment for building.

The python version should be greater than 2.7.3, after execute the script, please export python path as the following.

export PATH=/opt/python-2.7.3/bin/:$PATH

In addition, please sqlite3 and sqlite3-devel on your machine.


Have a great day,
Yiping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 项奖励

796 次查看
srak
Contributor III
facing same issue! I'm using ubuntu 18.06.4, trying to build for ls1046ardb
0 项奖励

1,319 次查看
B-Nagendra
Contributor I

hello NXP

I am facing similar issue on ubuntu 

installed python  2.7.6.  sqlite3 and libsqlite3-dev

trying to compile fsl-image-minimal for t1042d4rdb  

log:

from pysqlite2 import dbapi2 as sqlite3
ImportError: No module named pysqlite2

getting below error with python3.4 

Bitbake is not compatible with python v3

Please set up python v2 as your default python interpreter

 

what is the solution for this ?

0 项奖励

1,063 次查看
mertsalar137
Contributor I

Did you find a solution? I am facing same issue.

0 项奖励