USDPAA Compile Error

キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
693件の閲覧回数
sr
Contributor I

I have downloaded V1.6 SDK. Selected "p1020rdb" as machine type. Trying to do "bitbake usdpaa". I get the following:

ERROR: Function failed: do_compile (log file is located at

/home/sratliff/mySDK/QorIQ-SDK-V1.6-20140619-yocto/build_p1020rdb_release/tmp/work/p1020rdb-

fsl-linux-gnuspe/usdpaa/git-r0/temp/log.do_compile.14919)

ERROR: Logfile of failure stored in:

/home/sratliff/mySDK/QorIQ-SDK-V1.6-20140619-yocto/build_p1020rdb_release/tmp/work/p1020rdb-

fsl-linux-gnuspe/usdpaa/git-r0/temp/log.do_compile.14919

Log data follows:

| DEBUG: Executing shell function do_compile

| NOTE: make CC=powerpc-fsl-linux-gnuspe-gcc  -m32 -mcpu=8548 -mabi=spe

-mspe -mfloat-gprs=double

--sysroot=/home/sratliff/mySDK/QorIQ-SDK-V1.6-20140619-

yocto/build_p1020rdb_release/tmp/sysroots/p1020rdb

LD=powerpc-fsl-linux-gnuspe-ld

--sysroot=/home/sratliff/mySDK/QorIQ-SDK-V1.6-20140619-

yocto/build_p1020rdb_release/tmp/sysroots/p1020rdb

AR=powerpc-fsl-linux-gnuspe-ar

|  [CC] fmc_netcfg_parser.c (lib:usdpaa_syscfg)

| apps/lib/fmc_netcfg_parser.c:1:0: error: SPE not supported in this

| target

|  /* Copyright (c) 2010-2012 Freescale Semiconductor, Inc.

|  ^

| make: *** [apps/lib/objs_powerpc/usdpaa_syscfg_fmc_netcfg_parser.o]

Error 1

| ERROR: oe_runmake failed

| WARNING:

/home/sratliff/mySDK/QorIQ-SDK-V1.6-20140619-yocto/build_p1020rdb_release/tmp/work/p1020rdb-

fsl-linux-gnuspe/usdpaa/git-r0/temp/run.do_compile.14919:1

exit 1 from

|   exit 1

| ERROR: Function failed: do_compile (log file is located at

/home/sratliff/mySDK/QorIQ-SDK-V1.6-20140619-yocto/build_p1020rdb_release/tmp/work/p1020rdb-

fsl-linux-gnuspe/usdpaa/git-r0/temp/log.do_compile.14919)

ERROR: Task 6

(/home/sratliff/mySDK/QorIQ-SDK-V1.6-20140619-yocto/meta-fsl-ppc/recipes-

dpaa/usdpaa/usdpaa_git.bb,

do_compile) failed with exit code '1'

NOTE: Tasks Summary: Attempted 660 tasks of which 619 didn't need to be rerun and 1 failed.

Waiting for 0 running tasks to finish:

Does the p1020 support USDPAA? I'm a Freescale "newbie", but I've been told when the kernel is compiled for use, CFLAGS are set (in part) to  "-mno-spe -mspe=no -te500v2".

That sort-of looks like SPE is not supported???

Any help/pointers appreciated.

ラベル(1)
タグ(3)
0 件の賞賛
1 解決策
295件の閲覧回数
lunminliang
NXP Employee
NXP Employee

For the  question "Does the p1020 support USDPAA", I am afraid not.  See below table(partly) of features supported by each processor.

pastedImage_0.png

It's also available from Freescale Technical Information Center

元の投稿で解決策を見る

0 件の賞賛
2 返答(返信)
295件の閲覧回数
yipingwang
NXP TechSupport
NXP TechSupport

Hello Stanley Ratliff,


P1020 doesn't support USDPAA, "usdpaa" is only supported on QorIQ DPAA(Data Path Acceleration Architecture) platforms, such as P2041, P3, P4, P5, and T series, there is build limitation in Yocto build environment.


In SDK 1.6 Yocto build environment, before build Kernel "CFLAGS" is unset. Please refer to the following.

kernel_do_compile() {

        unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE

        ...

        oe_runmake uImage  CC="powerpc-fsl-linux-gnuspe-gcc  --sysroot=..." LD="powerpc-fsl-linux-gnuspe-ld.bfd  --sysroot=..."

}

If you want to build usdpaa, you could choose other platform which I mentioned above, for example p4080ds, and you need to install source ISO and e500mc Cache ISO.


Have a great day,
Yiping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

296件の閲覧回数
lunminliang
NXP Employee
NXP Employee

For the  question "Does the p1020 support USDPAA", I am afraid not.  See below table(partly) of features supported by each processor.

pastedImage_0.png

It's also available from Freescale Technical Information Center

0 件の賞賛