P1022 Custom board: Radeon problem

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

P1022 Custom board: Radeon problem

1,897件の閲覧回数
ppc-fan
Contributor I

Hi All,

 

I bought a P1022 custom board, last year.

 

Technical details:

 

P1022, Version: 1.1

2 core e500v2 1.2GHz revision 5.1

4 GB DDR3 RAM

PCIe x4 with x16 connector

U-Boot 2014.04-00124-g2c02fcb (Sep 20 2014 - 11:36:22)

OS: Debian 7.7 PowerPC and Debian 8.0 PowerPCSPE

Kernel 3.8.13-rt9 (config as attachment)

Radeon HD5450 1GB DDR3 VRAM

 

Debian 7.7 PowerPC and Debian 8.0 PowerPCSPE boot with the kernel 3.8.13-rt9 in the text mode without any problems. I can use X11 via fslfb (LCD) with the display resolution of 1024x768. But I can't use Debian with the Radeon HD5450. On U-Boot I have output with the Radeon but after the start of the Linux kernel, the screen has no output. But I saw with the serial console, that Linux booted without any problems and started gdm3 but unfortunately without screen output. I tried a lot of xorg configs and I played a lot with boot arguments for example video=radeonfb:1600x1200@60 etc but without any success. What I have to do to get X11 with the Radeon HD5450?

 

Cheers,

 

Christian

Original Attachment has been moved to: custom_board_3.8.13-rt9.config.zip

ラベル(1)
0 件の賞賛
返信
4 返答(返信)

1,034件の閲覧回数
ppc-fan
Contributor I

Hi,

It doesn't look like I'm running KMS:

[       14.868]  (II)  [KMS] drm report modesetting isn't supported.

I think the firmware of my Radeon HD5450 graphics card wasn't loaded because of the 36bit addressing but it is in the kernel. Is it possible to load a Radeon firmware with a Linux kernel on a P1022 board?

Thanks in advance,

Christian

0 件の賞賛
返信

1,034件の閲覧回数
yipingwang
NXP TechSupport
NXP TechSupport

Hello Christian Zigotzky,


In your Kernel configuration file, you configure the extra firmware location as the following.

CONFIG_EXTRA_FIRMWARE="radeon/R700_rlc.bin radeon/RV710_uvd.bin radeon/RV770_uvd.bin radeon/CYPRESS_me.bin radeon/CYPRESS_pfp.bin radeon/CYPRESS_rlc.bin radeon/CYPRESS_smc.bin radeon/CYPRESS_uvd.bin radeon/JUNIPER_me.bin radeon/JUNIPER_pfp.bin radeon/JUNIPER_rlc.bin radeon/JUNIPER_smc.bin radeon/REDWOOD_me.bin radeon/REDWOOD_pfp.bin radeon/REDWOOD_rlc.bin radeon/REDWOOD_smc.bin radeon/BTC_rlc.bin radeon/BARTS_me.bin radeon/BARTS_mc.bin radeon/BARTS_pfp.bin radeon/BARTS_smc.bin radeon/SUMO_uvd.bin radeon/CAICOS_me.bin radeon/CAICOS_mc.bin radeon/CAICOS_pfp.bin radeon/CAICOS_smc.bin radeon/TURKS_me.bin radeon/TURKS_mc.bin radeon/TURKS_pfp.bin radeon/TURKS_smc.bin radeon/CEDAR_me.bin radeon/CEDAR_pfp.bin radeon/CEDAR_rlc.bin radeon/CEDAR_smc.bin"

CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"

Please make sure the firmware is built into filesystem, and the path configured as "/lib/firmware/radeon" is correct, otherwise you need to modify Kernel configuration file.


Have a great day,
Yiping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 件の賞賛
返信

1,034件の閲覧回数
ppc-fan
Contributor I

Hi Yiping,

Thank you for your answer. The firmwares aren't the problem. They are in the kernel. I activated DRM in the kernel config. The kernel boots without any problems but if X11 starts then I get a scrambled screen. No output on the radeon or a scambled screen. Could it be that we have 36bit addressing on a 32bit CPU????? I saw a video about a P1022 board with a graphics card:  WireSpring Digital Signage P1022 Processor - |Freescale

Thanks in advance,

Christian

0 件の賞賛
返信

1,034件の閲覧回数
ppc-fan
Contributor I

At the boot time there is an error about a ring 0 test:

radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0xee270c00

radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0xee270c0c

[drm:r600_ring_test] *ERROR* radeon: ring 0 test failed (scratch(0x8504)=0xCAFEDEAD).

radeon 0000:01:00.0: disabling GPU acceleration

radeon 0000:01:00.0: ee79a600 unpin not necessary

[drm] Radeon Display Connectors

[drm] radeon: power management initialized

radeon 0000:01:00.0: registered panic notifier

0 件の賞賛
返信