TWR K60 HVAC web demo

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

TWR K60 HVAC web demo

ソリューションへジャンプ
1,534件の閲覧回数
UniversalTroope
Contributor III

I'm trying to run the HVAC webenabled demo on a TWR K60, using MQX 3.6.2 and IAR embedded workbench. The demo stops with "Waiting for ethernet cable plug in ...".

 

I have connected a cable, and the ethernet port LED's are lit. TWR-SER mode is RMII, 50MHz clock routed out, and TWR-K60 set to use that clock.

 

Any ideas?

ラベル(1)
タグ(1)
0 件の賞賛
1 解決策
811件の閲覧回数
anthony_huereca
NXP Employee
NXP Employee

Try putting the board in MII mode. The MCF52259 BSP is expecting that, not RMII. It would be the original jumper locations on the TWR-SER, which you can find in the TWR-SER user manual: http://cache.freescale.com/files/microcontrollers/doc/user_guide/TWRSERUM.pdf

元の投稿で解決策を見る

0 件の賞賛
4 返答(返信)
811件の閲覧回数
UniversalTroope
Contributor III

It seems this doesn't work:

 

ipcfg_get_link_active(IPCFG_default_enet_device)

 

If I disable this check, the demo works fine. Any tips on how to get the cable check working?

0 件の賞賛
811件の閲覧回数
PetrM
Senior Contributor I

Please make sure you have the switches on serial and processor boards set according to getting started manual.

It works for me.

 

PetrM

 

0 件の賞賛
811件の閲覧回数
UniversalTroope
Contributor III

Sorry, it was the security demo that stops on that cable check, but the hvac demo also doesn't correctly detect the link state.

0 件の賞賛
812件の閲覧回数
anthony_huereca
NXP Employee
NXP Employee

Try putting the board in MII mode. The MCF52259 BSP is expecting that, not RMII. It would be the original jumper locations on the TWR-SER, which you can find in the TWR-SER user manual: http://cache.freescale.com/files/microcontrollers/doc/user_guide/TWRSERUM.pdf

0 件の賞賛