Problem getting MQX task awareness to work in my project

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Problem getting MQX task awareness to work in my project

ソリューションへジャンプ
1,439件の閲覧回数
cktrod
Contributor I

I'm using a pro license for CodeWarrior version 5.9.0 build 3024 with MQX 3.4.  I've run the web_hvac_m52259evb demo and task awareness works fine. 

 

I created a project using the ColdFire New Project Wizard.  I then added a mqx bsp and psp cloned from the m52259evb builds.

 

The project runs and the context switches are occurring, but I don't have task awareness (nothing shows up under the MQX pull down besides check for new version and About TAD Plug-in).

 

With the web_hvac demo the task awareness appears after executing the first line of _sched_start_internal.  The same line executes in my project, but I don't get task awareness.

 

Any ideas?

 

Thanks,

Rod

0 件の賞賛
1 解決策
352件の閲覧回数
DavidS
NXP Employee
NXP Employee

Hi Rod,

Assuming you installed CW7.1 (and patch) first then FSLMQX3.4, the FSLMQX3.4 should have installed the following path into the CW7.1 directory chain:

C:\Program Files\Freescale\CodeWarrior for ColdFire V7.1\bin\Plugins\Debugger\rtos

If it is not present, then reinstall FSLMQX3.4 or just unzip the attached rtos folder into the CW7.1 path.

Restart CW, load and run FSLMQX demo/application, HALT, then look at the MQX or RTCS pull-downs to see TAD information.

If this doesn't work, then maybe the license is not really professional?

Regards,

David

元の投稿で解決策を見る

0 件の賞賛
4 返答(返信)
353件の閲覧回数
DavidS
NXP Employee
NXP Employee

Hi Rod,

Assuming you installed CW7.1 (and patch) first then FSLMQX3.4, the FSLMQX3.4 should have installed the following path into the CW7.1 directory chain:

C:\Program Files\Freescale\CodeWarrior for ColdFire V7.1\bin\Plugins\Debugger\rtos

If it is not present, then reinstall FSLMQX3.4 or just unzip the attached rtos folder into the CW7.1 path.

Restart CW, load and run FSLMQX demo/application, HALT, then look at the MQX or RTCS pull-downs to see TAD information.

If this doesn't work, then maybe the license is not really professional?

Regards,

David

0 件の賞賛
352件の閲覧回数
cktrod
Contributor I

David,

 

I am running CW7.1 w/the patch and there are three mqx dll files in the debugger\rtos directory.

 

I can run the mqx demo projects (like web_hvac_m52259evb) and TAD works fine.

 

We have 2 professional CW licenses, one with a dongle and the other on a server. 

My co-worker has used both licenses and his project has task awareness. 

I have used both licenses and haven't been able to see task awareness on my project.

 

For my project I cloned the bsp for m52259evb and modified it for my board (different address spaces, options and chip selects).

 

Could it be the location of MQX_init_struct or something in the lcf file?

 

Thanks,

Rod

0 件の賞賛
352件の閲覧回数
DavidS
NXP Employee
NXP Employee

Hi Rod,

Please make sure you only have one license.dat file in the CodeWarrior root directory.  Multiple license.dat files are bad to have in that directory.

Also check your target configuration (look at attached picture) under the CF Debugger Settings menu and select the appropriate MQX version to use in the Target OS: pull-down.

Lastly, did you try to run the same example as your co-worker?

Sorry you are having this issue.

Regards,

David

0 件の賞賛
352件の閲覧回数
cktrod
Contributor I

David,

 

I installed MQX 3.5 and my problem went away.

 

I can now select MQXv3.4 as the target O.S. for the debugger.  Previously I could only select up to MQXv3.3 for the target O.S. (w/MQXv3.4 installed).  Now with MQXv3.5 installed I can only select up to MQXv3.4 as the target O.S. for the debugger.  I don't know why the TAD seems to be one rev behind.

 

Thanks,

Rod

0 件の賞賛