MPC5777c On-line BIST

显示  仅  | 搜索替代 

MPC5777c On-line BIST

1,291 次查看
Contributor III

Hello everyone,

I am trying Online BIST on MPC5777C, i have selected clock configuartions as specified in referenece mannual and during run_online_bists()when it enters in either full, auto or reduced test after giving unlock stcu commands it jumps to location 0x800400 and stuck there during my debug session and not proceed further.

My code is as below: 

int main(void)

eTPU_AB_SCR.ECR_ENG1.B.MDIS = 1;   //disable etpu eng1 as recommended in RM
eTPU_AB_SCR.ECR_ENG2.B.MDIS = 1;   //disable etpu eng2 as recommended in RM
run_online_bists();                   //function from stcu guide for mpc5777c online_bist_3N45H.c
read_online_bists_results();    //function from stcu guide for mpc5777c online_bist_3N45H.c
return 0;

I have also disable etpu as shown above and it is recommended in RM. 

Test Cases gone through:

1. Pll0 clock set to 50 MHz.

2. Pll0 clock set to 200MHz.

3. Full test, auto test and reduced test configurations.

4. Checks done on two different chips.

5. This run_online_bists(); has both MBIST and LBIST exists, i have also tried only MBIST or LBIST same result no improvement.

Is i am missing something? please help me to get it done.

Thank you.

标记 (3)
3 回复数

898 次查看
NXP TechSupport
NXP TechSupport


I have written example code for MPC5777C as original SW in AN was not working for me.

Please find online BISTs in this link: 


898 次查看
NXP TechSupport
NXP TechSupport

Once you unlock STCU registers you cannot debug it in debugger as STCU implements watchdog.

Step on STCU init function and execute whole STCU configuration at once.

I expect that on 0x800400 you have unhanded IVOR1 exception.


898 次查看
Contributor III

Hi Peter,

I have try to run this MPC5777C BIST code and MBIST and  LBIST config run successfully but it stuck at RUNSW register as shown in below.

STCU2.RUNSW.R = 0x00000301; 

I also try to verify using  while (STCU2.RUNSW.B.RUNSW == 1); but it stuck here and doesn't came out of loop.  

You mention above that we can not debug STCU register so i try to flash the code but it doesn't work. Can you guide me how to flash the code in S32 Design Studio Power v1.2 as i only run the debug configuration. 


0 项奖励