Possible to debug M4 on QuadMax without hardware debugger?

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Possible to debug M4 on QuadMax without hardware debugger?

Contributor I


I'm trying to use the J-Link GDB server to debug an application running on the M4_0 core of an iMX8QM board.

Following the SDK for MEK-MIMX8QM Getting Started PDF (rev. 3 12/29/2020).

I flashed an SD card with the SCFW per the instructions in section 6.3, then built hello_world on a Linux VM per the instructions in 4.1.2, then tried to set up the debug connection on my Windows laptop per the instructions in 4.2.3.

Although the bullet point at the top of 4.2.3 implies a hardware J-Link probe is required ("You have a standalone J-Link pod..."), step 1 immediately below that implies it is optional ("If using a standalone J-Link debug pod, ...") so I proceeded under the latter assumption.

Step 4 on how to set up the J-Link GDB server has a missing figure ("Modify the settings as shown in <blank>.") but I made a best guess based on Figure 9.

The problem is that I keep getting the "No emulators connected via USB" dialog. I tried a couple of settings changes, like MIMX8QM5_M4_0 instead of QM6, SVD instead of JTAG, and 1000 instead of 4000 kHz speed, to no effect.

Obvious things checked: The board is fully powered up and functional -- I flashed hello_world via mkimg and verified the console output on a serial terminal. Also was able to boot the Linux distro on the original provided SD card.

So: is a hardware pod required or not to debug the M4 core on this board? And, if not, does anyone have other suggestions of things to try?


0 Kudos
0 Replies