config tool can't be used if the project is created by the chip not in the demo board

cancel
Showing results for 
Search instead for 
Did you mean: 

config tool can't be used if the project is created by the chip not in the demo board

Jump to solution
557 Views
Lurkersoo
Contributor III

I use MCUXpresso V11.5, and I’ve installed the related SDK. I create a new project based on LPC55S04, I found its config tool can’t be used. MIt shows that “Device Configuration tool does not support selected processor”. And there are no this kind of problem if the project is based on LPC55S06. Can you help to check what’s wrong with it?

 

0 Kudos
1 Solution
542 Views
liborukropec
NXP Employee
NXP Employee

Hi @Lurkersoo ,

for me the latest SDK LPC55S04 2.11 didn't work until I fixed the YAML part in clock_config.c and pin_mux.c - changing LPC55S06 => LPC55S04 otherwise the created Config Tools configuration was empty. If you face the same problem, delete the created *.mex file, fix the sources and open config tools again.

liborukropec_1-1642512932922.png

 

@ZhangJennie , could you please check the YAML parts for the LPC55S04 SDK?

 

Regards,

Libor

View solution in original post

10 Replies
525 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

HI all

Maybe my MCUXpresso IDE version is old. I use v11.3.0. SDK is the latest SDK LPC55S04 2.11.

YAML SETTINGS in clock_config.c and pin_mux.c is LPC55S06

I can open config tool from IDE without issue. 

ZhangJennie_0-1642567595758.png

Thanks,

Jun Zhang

 

0 Kudos
517 Views
Lurkersoo
Contributor III

Hi Jun,

We also can open the config tool. You need to try to add a pin configuration, thus you would find the issue. Thanks!

Lurkersoo

0 Kudos
513 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

Do you mean route a pin in pin configuration ? This is what I see. 

ZhangJennie_1-1642575765962.png

I can't see the error as mentioned in the original request.

 

 

 

 

0 Kudos
508 Views
Lurkersoo
Contributor III

Yes, it seems it's ok in you side. 

Lurkersoo

0 Kudos
543 Views
liborukropec
NXP Employee
NXP Employee

Hi @Lurkersoo ,

for me the latest SDK LPC55S04 2.11 didn't work until I fixed the YAML part in clock_config.c and pin_mux.c - changing LPC55S06 => LPC55S04 otherwise the created Config Tools configuration was empty. If you face the same problem, delete the created *.mex file, fix the sources and open config tools again.

liborukropec_1-1642512932922.png

 

@ZhangJennie , could you please check the YAML parts for the LPC55S04 SDK?

 

Regards,

Libor

372 Views
whiteliondd6
Contributor I

I am using KE16Z64VLD4 and facing the same issue. I make the necessary changes as you suggested changed the MCU in clock_config.c and peripheral.c files. Still, I am not able to use pin config tool and giving me the error: 

The settings do not match for all tools: Boards do not match: Clock 'FRDM_KE16Z' differs from peripherals 'FRDM_KE15Z'

Open configuration failed due to unknown reason

0 Kudos
367 Views
ErichStyger
Senior Contributor IV

Hi @whiteliondd6 ,

I suggest you make the necessary changes here:

ErichStyger_0-1645684111432.png

 

Erich

0 Kudos
362 Views
whiteliondd6
Contributor I

I already applied this step still, facing the error mentioned above

0 Kudos
530 Views
Lurkersoo
Contributor III

Hi Libor,

Yes, it seems that we have the same problem. Follow your instruction, it can work now. Thanks a lot!

@ZhangJennie It should be YAML SETTINGS issue, please help to check it. thanks!

0 Kudos
545 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

Hi Lurkersoo 

Thank you for contacting us.

Did you install the latest LPC55S04 to MCUXpresso IDE?

ZhangJennie_0-1642511118944.png

 

If you use the same SDK version but still have problem, please send your problem screenshot. I will check.

Have a nice day,

Jun Zhang

 

0 Kudos