MCUXpresso IDE doesn't keep the pin configuration

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
已解决

MCUXpresso IDE doesn't keep the pin configuration

跳至解决方案
1,508 次查看
chobin
Contributor III

Dear all,

I'm developing a project for microcontroller K20 using MCUXpresso IDE v11.0.0 [Build 2516] [2019-06-05].

I did the pin configuration using Pins section and I saved it.

I have this problem: when I close and open the project, the MCUXpresso doesn't load the pin configuratin and I have to repeat it evrey time.

Does someone know how can I configure the MCUXpresso to load the pin configuration?

Many thanks in advance for your support.

Kind Regards

0 项奖励
1 解答
1,444 次查看
chobin
Contributor III

Hello,

I solved the problem. There were two *.mix files in the workspace.

Thank you to all.

Kind Regards,

Stefano

在原帖中查看解决方案

0 项奖励
4 回复数
1,445 次查看
chobin
Contributor III

Hello,

I solved the problem. There were two *.mix files in the workspace.

Thank you to all.

Kind Regards,

Stefano

0 项奖励
1,444 次查看
soledad
NXP Employee
NXP Employee

Hi,

Thank you for your input.

Have a nice day!

Regards

Soledad

0 项奖励
1,444 次查看
marek-trmac
NXP Employee
NXP Employee

Hi,

Pins tool configuration is loaded automatically. Be careful if you have several projects in the workspace - Pins tool can open just one configuration. If you modify Pins configuration, hit [Update Code] button to save configuration and apply changes into source code.

Regards

Marek

Regards,
Marek
0 项奖励
1,444 次查看
liborukropec
NXP Employee
NXP Employee

Hello,

by Pins section you mean Pins tool probably. Is <projectname>.mex file created in the project? Is there just one *.mex file inside? Would be good if you can attach the mex here.

BTW - are you aware that there's IDE 11.1.0?

Regards,

Libor

0 项奖励