How to use MCU Link flash the MKM34Z265?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to use MCU Link flash the MKM34Z265?

118 Views
kresse
Contributor III

Dear 

I use MCU Link to flash the MKM34Z265 and it keeps failing.

 

01.png02.png03.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

I have measured the signal of SWD as follows, it seems that there is communication, but it will fail.

05.png06.png07.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Thanks,

Kris

 

 

Tags (3)
0 Kudos
7 Replies

98 Views
jingpan
NXP TechSupport
NXP TechSupport

Hi @kresse ,

Please try to use GUI flash tool to make a whole erase.

jingpan_0-1634115620870.png

 

Regards,

Jing

 

 

0 Kudos

79 Views
jingpan
NXP TechSupport
NXP TechSupport

Hi @kresse ,

Does the erase success?

What board do you use, TWR board or you own board?

 

Regards,

jing

0 Kudos

70 Views
kresse
Contributor III

Hi @jingpan 

 

My board and TWR-KM34Z75M both can't connect successfully.

If can't connect successfully, how can I erase the MCU?

 

Kresse

0 Kudos

63 Views
jingpan
NXP TechSupport
NXP TechSupport

Hi,

Maybe the problem is not caused by hardware or chip. TWR board has openSDA. It's default application is PEmicro. Can you use openSDA to debug? You also can change openSDA application to jlink.

Please take care of those jumper and power supply.

https://www.nxp.com/design/software/development-software/sensor-toolbox-sensor-development-ecosystem...

https://www.nxp.com/webapp/Download?colCode=TWRKM34Z75MUG

 

Regards,

Jing

0 Kudos

56 Views
kresse
Contributor III

Hi Jingpan

The TWR board can use OPENSDA to flash and debug. 

So you can see I remove the OPENSDA jump connect and try to use MCU Link to flash.

It just show can't connection succeeded.

 

Kris

0 Kudos

45 Views
jingpan
NXP TechSupport
NXP TechSupport

Hi,

I tried to use MCU-Link on TWR board just like you. It works fine. Since opensda can erase/program KM34, could it be the MCU-link problem? You can try to replace openSDA's application to CMSIS-DAP and try again. Please refer to this link to see how to update openSDA firmware.

https://www.nxp.com/design/software/development-software/sensor-toolbox-sensor-development-ecosystem...

 

Regards,

Jing

0 Kudos

88 Views
kresse
Contributor III

Dear @jingpan 

 

I had try it, but still show connect fail.

 

Kresse

0 Kudos