Can't debug MIMXRT1050-EVK 'hello world'

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't debug MIMXRT1050-EVK 'hello world'

3,027 Views
audio_guy
Contributor III

Using MCUXpresso I get the error message:

MCUXpresso RedlinkMulti Driver v10.1 (Nov 9 2017 16:45:39 - crt_emu_cm_redlink build 360)
Found chip XML file in C:/Users/pschuck/Documents/MCUXpressoIDE_10.1.0_589/workspace_iMX_RT/evkmimxrt1050_demo_apps_hello_world/Debug\MIMXRT1052xxxxx.xml
Reconnected to existing redlink server (PID 4294967295)
Connecting to probe 1 core 0 (server PID unknown) gave 'OK'
Probe Firmware: DAPLink CMSIS-DAP (ARM)
Serial Number: 0227000041114e450031300ac207004a92d1000097969900
VID:PID: 0D28:0204
USB Path: \\?\hid#vid_0d28&pid_0204&mi_03#8&572b11f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
debug interface type = <unknown> (DAP DP ID 0BD11477) over SWD
processor type = Cortex-M7 (CPU ID 410FC270)
number of h/w breakpoints = 8
number of flash patches = 0
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 0BD11477. CpuID: 410FC270. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Content of CoreSight Debug ROM(s):
RBASE E00FD000: CID B105100D PID 000008E88C ROM dev (type 0x1)
ROM 1 E00FE000: CID B105100D PID 04000BB4C8 ROM dev (type 0x1)
ROM 2 E00FF000: CID B105100D PID 04000BB4C7 ROM dev (type 0x1)
ROM 3 E000E000: CID B105E00D PID 04000BB00C ChipIP dev SCS (type 0x0)
ROM 3 E0001000: CID B105E00D PID 04000BB002 ChipIP dev DWT (type 0x0)
ROM 3 E0002000: CID B105E00D PID 04000BB00E ChipIP dev (type 0x0)
ROM 3 E0000000: CID B105E00D PID 04000BB001 ChipIP dev ITM (type 0x0)
ROM 2 E0041000: CID B105900D PID 04001BB975 ARCH 23B:4A13r0 CoreSight dev type 0x13 Trace Source - core
ROM 2 E0042000: CID B105900D PID 04004BB906 CoreSight dev type 0x14 Debug Control - Trigger, e.g. ECT
ROM 1 E0040000: CID B105900D PID 04000BB9A9 CoreSight dev type 0x11 Trace Sink - TPIU
ROM 1 E0043000: CID B105F00D PID 04001BB101 System dev (type 0x0)
CM7 Rev. 0.0 DTCM: 512KB ITCM: 512KB
LoUU: Level 2: LoC: Level 2
Level 1 Cache Type: Instruction+Data
ICache 32K: WT: Y WB: Y RA: Y WA: Y NumSets: 512 Assoc: 2 LineSize: 8
DCache 32K: WT: Y WB: Y RA: Y WA: Y NumSets: 256 Assoc: 4 LineSize: 8
failed to find a target memory area to use to test the Debug Access Port
required information about vendor NXP chip MIMXRT1052xxxxx not found
Failed on chip setup: Ec(01). Invalid part, XML, or configuration.
error closing down debug session - Ee(FF). Redlink interface error 255.

I updated OpenSDA to 'k20dx_mimxrt1050_evk_hyper_if_crc.bin' and it still does not work. Any ideas? 

0 Kudos
11 Replies

1,169 Views
asick
Contributor III

Target board - MIMX1050-EVK

I'm using MCUXpresso IDE v10.3.0 [Build 2200] [2018-12-03]

I have MCUXpresso sdk Version: 2.3.0

When i hit debug on IDE getting 

Executing flash operation 'Program' (Program file into flash: evkmimxrt1050_hello_world_xip_test_app_1.axf) - Wed Jan 09 10:31:45 IST 2019
Checking MCU info...
Scanning for targets...
Executing flash action...
MCUXpresso IDE RedlinkMulti Driver v10.3 (Nov 28 2018 02:33:57 - crt_emu_cm_redlink.exe build 748)
( 0) Reading remote configuration
Wc(03). No cache support.
Found chip XML file in C:/Users/SacraSystemsWS5/Documents/MCUXpressoIDE_10.3.0_2200/workspace/evkmimxrt1050_hello_world_xip_test_app_1/Debug\MIMXRT1052xxxxx.xml
( 5) Remote configuration complete
Reconnected to existing link server
Connecting to probe 1 core 0 (using server started externally) gave 'OK'
Probe Firmware: DAPLink CMSIS-DAP (ARM)
Serial Number: 0225000041114e45000d3004b60f001da6e1000097969900
VID:PID: 0D28:0204
USB Path: \\?\hid#vid_0d28&pid_0204&mi_03#8&6cac4b3&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Using memory from core 0 after searching for a good core
( 30) Emulator Connected
( 40) Debug Halt
( 50) CPU ID
debug interface type = Cortex-M7 (DAP DP ID 0BD11477) over SWD TAP 0
processor type = Cortex-M7 (CPU ID 00000C27) on DAP AP 0
number of h/w breakpoints = 8
number of flash patches = 0
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 0BD11477. CpuID: 00000C27. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Content of CoreSight Debug ROM(s):
RBASE E00FD000: CID B105100D PID 000008E88C ROM (type 0x1)
ROM 1 E00FE000: CID B105100D PID 04000BB4C8 ROM (type 0x1)
ROM 2 E00FF000: CID B105100D PID 04000BB4C7 ROM (type 0x1)
ROM 3 E000E000: CID B105E00D PID 04000BB00C Gen SCS (type 0x0)
ROM 3 E0001000: CID B105E00D PID 04000BB002 Gen DWT (type 0x0)
ROM 3 E0002000: CID B105E00D PID 04000BB00E Gen (type 0x0)
ROM 3 E0000000: CID B105E00D PID 04000BB001 Gen ITM (type 0x0)
ROM 2 E0041000: CID B105900D PID 04001BB975 CSt ARM ETMv4.0 type 0x13 Trace Source - Core
ROM 2 E0042000: CID B105900D PID 04004BB906 CSt type 0x14 Debug Control - Trigger, e.g. ECT
ROM 1 E0040000: CID B105900D PID 04000BB9A9 CSt type 0x11 Trace Sink - TPIU
ROM 1 E0043000: CID B105F00D PID 04001BB101 Sys (type 0x0)
NXP: MIMXRT1052xxxxx
DAP stride is 1024 bytes (256 words)
Inspected v.2 External Flash Device on SPI MIMXRT1050-EVK_S26KS512S.cfx
Image 'MIMXRT1050-EVK_S26KS512SOct 19 2017 16:37:47'
Opening flash driver MIMXRT1050-EVK_S26KS512S.cfx
Sending VECTRESET to run flash driver
Flash variant 'S26KS512S' detected (64MB = 256*256K at 0x60000000)
Closing flash driver MIMXRT1050-EVK_S26KS512S.cfx
( 65) Chip Setup Complete
Connected: was_reset=true. was_stopped=true
( 70) License Check Complete
Loading 'evkmimxrt1050_hello_world_xip_test_app_1.axf' ELF 0x60000000 len 0x51E4
Opening flash driver MIMXRT1050-EVK_S26KS512S.cfx (already resident)
Sending VECTRESET to run flash driver
Flash variant 'S26KS512S' detected (64MB = 256*256K at 0x60000000)
Writing 20964 bytes to address 0x60000000 in Flash
( 0) Mass erasing Flash
Mass erased flash in 3775msec
1 of 1 ( 0) Writing pages 0-0 at 0x60000000 with 20964 bytes
( 0) at 60000000: 0 bytes - 0/20964
( 78) at 60000000: 16384 bytes - 16384/20964
(100) at 60004000: 16384 bytes - 32768/20964
Wrote sector 0-0 with 20964 bytes in 1422msec
Closing flash driver MIMXRT1050-EVK_S26KS512S.cfx
(100) Finished writing Flash successfully.
Flash Write Done
Loaded 0x51E4 bytes in 5742ms (about 3kB/s)
Reset target (system)
Starting execution using system reset
error on restart - Nn(05). Wire ACK Fault in DAP access
(100) Target Connection Failed
request to clear DAP error failed - status 5
request to clear DAP error failed - status 5
error closing down debug session - Nn(05). Wire ACK Fault in DAP access
Unable to perform operation!
Command failed with exit code 1

0 Kudos

1,168 Views
BlackNight
NXP Employee
NXP Employee

Are you using the EVK or EVKB (i.MX RT1050 EVK vs. EVKB)?

I recommend that you check the guide in Overview of using the MIMXRT1050-EVK(B) with MCUXpresso IDE

In addition to that, I suggest that you power the board with an external power supply (see MCUXpresso IDE with i.MX RT1052 Crossover Processor).

I hope this helps,

Erich

0 Kudos

1,169 Views
asick
Contributor III

Thanks Erich,

I'm using MIMXRT1050EVK board

0 Kudos

1,169 Views
ryanshuttlewort
Contributor IV

Hello, I'm having the same issue. The mass erase procedure had some effect but enumeration under OSX is unreliable as is programming and debugging.  There is still no enumeration under Linux at all.  Please see the following programming errors, thanks.

MCUXpresso RedlinkMulti Driver v10.1 (Nov  9 2017 16:49:12 - crt_emu_cm_redlink build 360)
Found chip XML file in /Users/ryan/Documents/MCUXpressoIDE_10.1.0/workspace/evkmimxrt1050_demo_apps_hello_world_xip/Debug/MIMXRT1052xxxxx.xml
Reconnected to existing redlink server (PID 4294967295)
Connecting to probe 1 core 0 (server PID unknown) gave 'OK'
Probe Firmware: DAPLink CMSIS-DAP (ARM)
Serial Number:  0227000041114e45003d300dc40300105ab1000097969900
VID:PID:  0D28:0204
USB Path: USB_0d28_0204_14220000_ff00
debug interface type      = <unknown> (DAP DP ID 0BD11477) over SWD
processor type            = Cortex-M7 (CPU ID 410FC270)
number of h/w breakpoints = 8
number of flash patches   = 0
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 0BD11477. CpuID: 410FC270. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Content of CoreSight Debug ROM(s):
RBASE E00FD000: CID B105100D PID 000008E88C ROM dev (type 0x1)
ROM 1 E00FE000: CID B105100D PID 04000BB4C8 ROM dev (type 0x1)
ROM 2 E00FF000: CID B105100D PID 04000BB4C7 ROM dev (type 0x1)
ROM 3 E000E000: CID B105E00D PID 04000BB00C ChipIP dev SCS (type 0x0)
ROM 3 E0001000: CID B105E00D PID 04000BB002 ChipIP dev DWT (type 0x0)
ROM 3 E0002000: CID B105E00D PID 04000BB00E ChipIP dev (type 0x0)
ROM 3 E0000000: CID B105E00D PID 04000BB001 ChipIP dev ITM (type 0x0)
ROM 2 E0041000: CID B105900D PID 04001BB975 ARCH 23B:4A13r0 CoreSight dev type 0x13 Trace Source - core
ROM 2 E0042000: CID B105900D PID 04004BB906 CoreSight dev type 0x14 Debug Control - Trigger, e.g. ECT
ROM 1 E0040000: CID B105900D PID 04000BB9A9 CoreSight dev type 0x11 Trace Sink - TPIU
ROM 1 E0043000: CID B105F00D PID 04001BB101 System dev (type 0x0)
CM7 Rev. 0.0  DTCM: 512KB  ITCM: 512KB
LoUU: Level 2: LoC: Level 2
Level 1 Cache Type: Instruction+Data
ICache 32K: WT: Y WB: Y RA: Y WA: Y NumSets:  512 Assoc:   2 LineSize:  8
DCache 32K: WT: Y WB: Y RA: Y WA: Y NumSets:  256 Assoc:   4 LineSize:  8
Inspected v.2 External Flash Device on SPI using SPIFI lib MIMXRT1050-EVK_S26KS512S.cfx
Image 'MIMXRT1050-EVK_S26KS512SOct 19 2017 16:37:47'
Opening flash driver MIMXRT1050-EVK_S26KS512S.cfx
Sending VECTRESET to run flash driver
flash variant 'S26KS512S' detected (64MB = 256*256K at 0x60000000)
Closing flash driver MIMXRT1050-EVK_S26KS512S.cfx
NXP: MIMXRT1052xxxxx
Connected: was_reset=false. was_stopped=true
MCUXpresso Free License - Downloads unlimited
Awaiting telnet connection to port 3330 ...
GDB nonstop mode enabled
Opening flash driver MIMXRT1050-EVK_S26KS512S.cfx (already resident)
Sending VECTRESET to run flash driver
Writing 24668 bytes to address 0x60000000 in Flash
Erased/Wrote page  0-0 with 24668 bytes in 1375msec
Closing flash driver MIMXRT1050-EVK_S26KS512S.cfx
Flash Write Done
Flash Program Summary: 24668 bytes in 1.38 seconds (17.52 KB/sec)
Starting execution using system reset and halt target
Stopped: Halt
After error Nn(05). Wire ACK Fault in DAP access -
Failed to read address register in DAP - Ee(FF). Redlink interface error 255.
After error Em(17). Debug port inaccessible after access at location 0x600029F0 -
Failed to read address register in DAP - Ee(FF). Redlink interface error 255.
Target error from Read Memory: Em(17). Debug port inaccessible after access at location 0x600029F0
After error Nn(05). Wire ACK Fault in DAP access -
Failed to read address register in DAP - Ee(FF). Redlink interface error 255.
After error Em(17). Debug port inaccessible after access at location 0x600029F0 -
Failed to read address register in DAP - Ee(FF). Redlink interface error 255.
Target error from Read Memory: Em(17). Debug port inaccessible after access at location 0x600029F0


MCUXpresso RedlinkMulti Driver v10.1 (Nov  9 2017 16:49:12 - crt_emu_cm_redlink build 360)
Found chip XML file in /Users/ryan/Documents/MCUXpressoIDE_10.1.0/workspace/evkmimxrt1050_demo_apps_hello_world_xip/Debug/MIMXRT1052xxxxx.xml
Reconnected to existing redlink server (PID 4294967295)
Connecting to probe 1 core 0 (server PID unknown) gave 'OK'
Probe Firmware: DAPLink CMSIS-DAP (ARM)
Serial Number:  0227000041114e45003d300dc40300105ab1000097969900
VID:PID:  0D28:0204
USB Path: USB_0d28_0204_14220000_ff00
connection failed - Ee(FF). Redlink interface error 255... Retrying
Failed on connect: Ee(FF). Redlink interface error 255.
Connected&Reset. Was: NotConnected. DpID: 00000000. CpuID: 00000000. Info: <None>
Last stub error 0: OK
Last sticky error: 0x0 AIndex: 0
Debug bus selected: MemAp 0
DAP Speed test unexecuted or failed
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
(100) Target Connection Failed
error closing down debug session - Ee(FF). Redlink interface error 255.

0 Kudos

1,169 Views
lpcxpresso_supp
NXP Employee
NXP Employee

We have a theory. Please can you follow the process to mass erase the Hyperflash that is detailed in the Troubleshooting section of https://community.nxp.com/community/mcuxpresso/mcuxpresso-ide/blog/2017/12/07/overview-of-using-the-... 

After doing this, power the board down and then back up again. And then try debugging your project again. Does this then work?

Regards,

MCUXpresso IDE Support

1,169 Views
craigsmith
Contributor III

Success!  This works for me also!  :smileyhappy:

Using LPC-Link2 with freertos uart sdk project.

0 Kudos

1,169 Views
audio_guy
Contributor III

This step worked for me! I got the 'hello_world_xip' example to run.

thanks

0 Kudos

1,169 Views
bernhardfink
NXP Employee
NXP Employee

We have seen this type of error with the existing SDK and with boards in the A4 version. The same SDK works fine with A2 boards. Most likely the reason is that the A4 boards have a new chip revision on it which is not compatible with the manifest file of the SDK. That's why you get this error:

Failed on chip setup: Ec(01). Invalid part, XML, or configuration.

MCUXpresso takes the information from the manifest file, compares it during the debugger setup with the actual chip id and detects a mismatch.

There are three solutions:

  • Take a board revision A2
  • Tweak the manifest file (to be honest, without looking into it I don't even know if this works)
  • Wait for NXP to update the SDK to the new chip version.

Regards,

Bernhard.

1,169 Views
craigsmith
Contributor III

Hi Bernhard,

Thanks for the information, that sounds like it could be what is going on.  I do indeed have version A4.

Hopefully NXP updates the SDK soon so I can actually start developing with the dev kit.

Craig

0 Kudos

1,169 Views
craigsmith
Contributor III

I also have this issue and anxiously await for a solution.  I have also tried using the LPC-Link2 attached to the JTAG port on the dev board, exactly the same result.  I have tried many of the example projects from the SDK, same result.  Have even tried removing the SDRAM from the memory details in project properties (as I found some notes saying it may be trying to write to the SDRAM).  No effect.

Trace using LPC-Link 2 connected to JTAG port on MIMXRT1050-EVK below:

MCUXpresso RedlinkMulti Driver v10.1 (Nov 9 2017 16:45:39 - crt_emu_cm_redlink build 360)
Found chip XML file in D:/Integrity/MCUXpressoIDE_10.1.0_589/workspace/evkmimxrt1050_cmsis_driver_examples_lpuart_interrupt_transfer_cmsis_lpuart_interrupt_transfer/Debug\MIMXRT1052xxxxx.xml
Reconnected to existing redlink server (PID 4294967295)
Connecting to probe 1 core 0 (server PID unknown) gave 'OK'
Probe Firmware: LPC-LINK2 CMSIS-DAP V5.183 (NXP Semiconductors)
Serial Number: JQDYIRAU
VID:PID: 1FC9:0090
USB Path: \\?\hid#vid_1fc9&pid_0090&mi_00#8&10d723f&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
debug interface type = <unknown> (DAP DP ID 0BD11477) over SWD
processor type = Cortex-M7 (CPU ID 410FC270)
number of h/w breakpoints = 8
number of flash patches = 0
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 0BD11477. CpuID: 410FC270. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Content of CoreSight Debug ROM(s):
RBASE E00FD000: CID B105100D PID 000008E88C ROM dev (type 0x1)
ROM 1 E00FE000: CID B105100D PID 04000BB4C8 ROM dev (type 0x1)
ROM 2 E00FF000: CID B105100D PID 04000BB4C7 ROM dev (type 0x1)
ROM 3 E000E000: CID B105E00D PID 04000BB00C ChipIP dev SCS (type 0x0)
ROM 3 E0001000: CID B105E00D PID 04000BB002 ChipIP dev DWT (type 0x0)
ROM 3 E0002000: CID B105E00D PID 04000BB00E ChipIP dev (type 0x0)
ROM 3 E0000000: CID B105E00D PID 04000BB001 ChipIP dev ITM (type 0x0)
ROM 2 E0041000: CID B105900D PID 04001BB975 ARCH 23B:4A13r0 CoreSight dev type 0x13 Trace Source - core
ROM 2 E0042000: CID B105900D PID 04004BB906 CoreSight dev type 0x14 Debug Control - Trigger, e.g. ECT
ROM 1 E0040000: CID B105900D PID 04000BB9A9 CoreSight dev type 0x11 Trace Sink - TPIU
ROM 1 E0043000: CID B105F00D PID 04001BB101 System dev (type 0x0)
CM7 Rev. 0.0 DTCM: 512KB ITCM: 512KB
LoUU: Level 2: LoC: Level 2
Level 1 Cache Type: Instruction+Data
ICache 32K: WT: Y WB: Y RA: Y WA: Y NumSets: 512 Assoc: 2 LineSize: 8
DCache 32K: WT: Y WB: Y RA: Y WA: Y NumSets: 256 Assoc: 4 LineSize: 8
failed to find a target memory area to use to test the Debug Access Port
required information about vendor NXP chip MIMXRT1052xxxxx not found
Failed on chip setup: Ec(01). Invalid part, XML, or configuration.
error closing down debug session - Ee(FF). Redlink interface error 255.

0 Kudos

1,169 Views
lpcxpresso_supp
NXP Employee
NXP Employee

I'm sorry for the problems you are seeing - you will see from other MCUXpresso IDE community threads that we have received several other similarly reports. We are currently investigating these and will post an update once we know more.

In the meantime, you may wish to check out our blog article:

 Overview of using the MIMXRT1050-EVK with MCUXpresso IDE 

and follow the instructions for installing the latest debug probe firmware.

Regards,

MCUXpresso IDE Support

0 Kudos