Not able to change Port speed using ethtool on LS-1088ARDB-PB

cancel
Showing results for 
Search instead for 
Did you mean: 

Not able to change Port speed using ethtool on LS-1088ARDB-PB

Jump to solution
184 Views
ashutoshharry
Contributor II

Hi @yipingwang 

 

i am not able to change port speed as its 10G interface and want to change it to 1G for traffic testing.

 

any clues will be helpful

 

logs and command below:

--------------------------------------

root@OpenWrt:~# ethtool eth1
Settings for eth1:
Supported ports: [ ]
Supported link modes: Not reported
Supported pause frame use: No
Supports auto-negotiation: No
Supported FEC modes: Not reported
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Advertised FEC modes: Not reported
Speed: 10000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Link detected: yes
root@OpenWrt:~# ethtool -s eth1 speed 1000 duplex full
root@OpenWrt:~# ethtool eth1
Settings for eth1:
Supported ports: [ ]
Supported link modes: Not reported
Supported pause frame use: No
Supports auto-negotiation: No
Supported FEC modes: Not reported
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Advertised FEC modes: Not reported
Speed: 10000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Link detected: yes
root@OpenWrt:~# ethtool -s eth1 speed 1000
Cannot advertise speed 1000
root@OpenWrt:~# dmesg -n 8
root@OpenWrt:~# ethtool eth1
Settings for eth1:
Supported ports: [ ]
Supported link modes: Not reported
Supported pause frame use: No
Supports auto-negotiation: No
Supported FEC modes: Not reported
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Advertised FEC modes: Not reported
Speed: 10000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Link detected: yes
root@OpenWrt:~#

 

 

Tags (1)
0 Kudos
1 Solution
149 Views
yipingwang
NXP TechSupport
NXP TechSupport

This operation is not supported in LSDK or OpenWrt.

View solution in original post

4 Replies
160 Views
ashutoshharry
Contributor II

root@OpenWrt:~# ethtool eth1
Settings for eth1:
Supported ports: [ ]
Supported link modes: Not reported
Supported pause frame use: No
Supports auto-negotiation: No
Supported FEC modes: Not reported
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Advertised FEC modes: Not reported
Speed: 10000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Link detected: yes
root@OpenWrt:~# ethtool -s eth1 speed 1000 duplex full autoneg off
root@OpenWrt:~#
root@OpenWrt:~# ethtool eth1
Settings for eth1:
Supported ports: [ ]
Supported link modes: Not reported
Supported pause frame use: No
Supports auto-negotiation: No
Supported FEC modes: Not reported
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Advertised FEC modes: Not reported
Speed: 10000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Link detected: yes

0 Kudos
150 Views
yipingwang
NXP TechSupport
NXP TechSupport

This operation is not supported in LSDK or OpenWrt.

View solution in original post

162 Views
ashutoshharry
Contributor II

root@OpenWrt:~# ethtool eth1
Settings for eth1:
Supported ports: [ ]
Supported link modes: Not reported
Supported pause frame use: No
Supports auto-negotiation: No
Supported FEC modes: Not reported
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Advertised FEC modes: Not reported
Speed: 10000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Link detected: yes
root@OpenWrt:~# ethtool -s eth1 speed 1000 duplex full autoneg off
root@OpenWrt:~#
root@OpenWrt:~# ethtool eth1
Settings for eth1:
Supported ports: [ ]
Supported link modes: Not reported
Supported pause frame use: No
Supports auto-negotiation: No
Supported FEC modes: Not reported
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Advertised FEC modes: Not reported
Speed: 10000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Link detected: yes

 

same result 

0 Kudos
168 Views
yipingwang
NXP TechSupport
NXP TechSupport

Do you use dpmac.1 or dpmac.2?

dpmac.1 is optical port, it cannot be switched to 1G mode.

dpmac.2 is copper port, you could try the following command.

ethtool -s eth1 speed 1000 duplex full autoneg off

0 Kudos