Does SDHC_VS have to be enabled in LS1043A to use UHS-I

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 

Does SDHC_VS have to be enabled in LS1043A to use UHS-I

685 次查看
brianpaiva
Contributor III

I'm struggling to support UHS-I on my LS1043ARDB board and I noticed that by default the SDHC_VS signal isn't enabled in RCW[SPI_EXT].  Does this mean that writing 1 to PROCTL[VOLT_SEL] does nothing if RCW[SPI_EXT] isn't set to 001?  And if I understand this correctly you can't support both UHS-I mode on an SD Card and SPI at the same time?  Setting RCW[SPI_EXT] to 001 didn't solve my problem so there must be more to it.  Do I also need to enable SDHC_CMD_DIR by setting RCW[SPI_BASE] to 11b?  I attempted this, but in Code Warrior it does not give me an option to set RCW[SPI_BASE] to 11b.  I can only set it to 0b00, 0b01 or 0b10.

标签 (1)
标记 (1)
0 项奖励
2 回复数

537 次查看
Pavel
NXP Employee
NXP Employee

Check your configuration using the Table 3-8 of the LS1043a Reference Manual Rev 3:https://www.nxp.com/webapp/Download?colCode=LS1043ARM&Parent_nodeId=1412692250778715498030&Parent_pa... If the SDHC_VS is not enabled, the SPI_CS_B[0] pin is not connected to the eSDHC controller.Writing to the PROCTL[VOLT_SEL] does not change state of the SPI_CS_B[0] pin.


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 项奖励

537 次查看
brianpaiva
Contributor III

So I haven't got past this.  Is there anyone who has tried this configuration?

0 项奖励