Unable to connect wire for probe index 1. Error: Wire Ack Fault - target connected?

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to connect wire for probe index 1. Error: Wire Ack Fault - target connected?

55 Views
amulya0129
Contributor I

Hi, im new user of LPC55S16 evk board. I had configured GPIO P0_11 to output to BLU-NRG Reset pin. After Flashing the code, when i tried to flash the code next time, i was unable to flash the code and i got an error "Unable to connect wire for probe index 1. Error: Wire Ack Fault - target connected? Unable to connect wire for probe index 1. Error: Wire Ack Fault - target connected? Error: Wire Ack Fault - target connected? at com.nxp.mcuxpresso.core.debug.support.linkserver.redlink.client.RedlinkServerClient.checkServerReply(RedlinkServerClient.java:214) at com.nxp.mcuxpresso.core.debug.support.linkserver.redlink.client.RedlinkServerClient.wireConnect(RedlinkServerClient.java:1159) at com.nxp.mcuxpresso.core.debug.support.linkserver.emulators.jtag.AbstractJtagDiscovery.ideConnect(AbstractJtagDiscovery.java:207) at com.nxp.mcuxpresso.core.debug.support.linkserver.emulators.jtag.AbstractJtagDiscovery.connect(AbstractJtagDiscovery.java:187) at com.nxp.mcuxpresso.core.debug.support.linkserver.emulators.jtag.AbstractJtagDiscovery.discover(AbstractJtagDiscovery.java:146) at com.nxp.mcuxpresso.core.debug.support.linkserver.emulators.TargetDiscovery.jtagDiscovery(TargetDiscovery.java:444) at com.nxp.mcuxpresso.core.debug.support.linkserver.launch.LaunchScriptUtils.getEmulatorInfo(LaunchScriptUtils.java:247) at com.nxp.mcuxpresso.core.debug.support.linkserver.launch.LaunchScriptUtils.init(LaunchScriptUtils.java:487) at com.nxp.mcuxpresso.core.debug.support.linkserver.launch.LaunchScriptUtils.(LaunchScriptUtils.java:155) at com.nxp.mcuxpresso.core.debug.support.linkserver.launch.LaunchScriptUtils.(LaunchScriptUtils.java:142) at com.nxp.mcuxpresso.core.debug.support.linkserver.services.TargetDiscoveryService.getTargetDiscovery(TargetDiscoveryService.java:138) at com.nxp.mcuxpresso.core.debug.support.linkserver.override.LSFinalLaunchSequence$TargetDiscoveryJob.run(LSFinalLaunchSequence.java:113) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63) Please can u suggest me a solution as im unable to flash the code

0 Kudos
2 Replies

42 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello amulya0129,

As converse said, disconnect all the debug connect , then connect again:

Alice_Yang_0-1632707660999.png

 

BR

Alice

 

 

0 Kudos

48 Views
converse
Senior Contributor V

The error is implying that you already have a debug session connected to the chip. Did you terminate your previous debug session? Read the Debug section of the User Guide for more details on starting and stopping debug sessions.

0 Kudos