Why do I have packet loss on TWR-KV58F220M with TWR-SER?

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Why do I have packet loss on TWR-KV58F220M with TWR-SER?

ソリューションへジャンプ
546件の閲覧回数
aliismail
Contributor IV

Hardware and Configuration:

TWR-KV58F220M

TWR-SER (J2 3-4, J3 2-3, J12 9-10)

IDE       : IAR 7.8

SDK      : 2.3.1

Example: lwip udp echo

I am trying out the lwip udp echo example on my TWR-KV58F220M and TWR-SER. I am sure I have configured the jumpers correctly:

J2 for 50MHz PHY Clock

J3 for 50MHz CLOCKIN0

J12 for RMII

When I run the udp echo exampe on the dev board, I notice a lot of packet drops. If I ping the IP address defined in the example, I do not always get a reply. Also, I wrote a simple packet sending program to send udp packets to the KV5 and it does not get 7% of packets sent to it. Anyone have ideas? I suspect that this isn't normal.

0 件の賞賛
1 解決策
381件の閲覧回数
Hui_Ma
NXP TechSupport
NXP TechSupport

Hi,

The TWR-KV58F220M board 50MHz clock need resourcing from TWR-SER board, please disable the TWR-KV58F220M board 50MHz oscillator with J29 shunt on.
For the detailed clock setting for TWR-KV58F220M board, please check below info at [lwip_udpecho] project <readme.txt> file:

Board settings
==============
TWR-SER:
    - RMII mode - J2 3-4 shunt on, J3 2-3 shunt on, J12 shunt on 9,10.
Clock setting for TWR-KV58F220M board
    - J29 1-2 shunt on.
    - Place R110 with 0 Ohm resister.
    - J11 no shunt, to avoid wrong reset button behaviour.
    
BTW: The MCUXPresso SDK V2.3.1 for TWR-KV58F220M board [lwip_udpecho] project supported below IDE software:
Toolchain supported
===================
- IAR embedded Workbench 8.11.3
- Keil MDK 5.23
- GCC ARM Embedded 6-2017-q2
- Kinetis Development Studio IDE 3.2.0
- MCUXpresso10.1.0

The major issue is the TWR-KV58F220M board should use TWR-SER board 50MHz CLKIN.

Wish it helps.   


Have a great day,
Mike

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

元の投稿で解決策を見る

0 件の賞賛
1 返信
382件の閲覧回数
Hui_Ma
NXP TechSupport
NXP TechSupport

Hi,

The TWR-KV58F220M board 50MHz clock need resourcing from TWR-SER board, please disable the TWR-KV58F220M board 50MHz oscillator with J29 shunt on.
For the detailed clock setting for TWR-KV58F220M board, please check below info at [lwip_udpecho] project <readme.txt> file:

Board settings
==============
TWR-SER:
    - RMII mode - J2 3-4 shunt on, J3 2-3 shunt on, J12 shunt on 9,10.
Clock setting for TWR-KV58F220M board
    - J29 1-2 shunt on.
    - Place R110 with 0 Ohm resister.
    - J11 no shunt, to avoid wrong reset button behaviour.
    
BTW: The MCUXPresso SDK V2.3.1 for TWR-KV58F220M board [lwip_udpecho] project supported below IDE software:
Toolchain supported
===================
- IAR embedded Workbench 8.11.3
- Keil MDK 5.23
- GCC ARM Embedded 6-2017-q2
- Kinetis Development Studio IDE 3.2.0
- MCUXpresso10.1.0

The major issue is the TWR-KV58F220M board should use TWR-SER board 50MHz CLKIN.

Wish it helps.   


Have a great day,
Mike

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 件の賞賛