WDOG_CS not showing correct value in debug mode using Jlink

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

WDOG_CS not showing correct value in debug mode using Jlink

ソリューションへジャンプ
1,050件の閲覧回数
MithileshKumar
Contributor II

Hi,

I am using MKE15Z series MCU. As per datasheet the default value of WDOG_CS should be 0x2980 but what obtained is 0x420 which is incorrect. But with CMSIS-DAP getting the correct value.

Is it related to debugger. If yes, is there any workaround for this.

 

ラベル(1)
0 件の賞賛
1 解決策
1,039件の閲覧回数
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi MithileshKumar,

Did you try to read the value of WDOG_CS through code? Check if the value is the same as the debugger register view?

If you still have problems after updating the J-Link software, it is recommended to submit a technical service request to SEGGER.

Best Regards,
Robin
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

元の投稿で解決策を見る

2 返答(返信)
1,033件の閲覧回数
MithileshKumar
Contributor II

Yes I am trying to read through code. At startup, the register view for WDOG_CS is shared in the image. But the reset value of the register should be 0x2980(As per datasheet).

0 件の賞賛
1,040件の閲覧回数
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi MithileshKumar,

Did you try to read the value of WDOG_CS through code? Check if the value is the same as the debugger register view?

If you still have problems after updating the J-Link software, it is recommended to submit a technical service request to SEGGER.

Best Regards,
Robin
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------