FRDM-KL26Z eval board, openSDA not working.

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
已解决

FRDM-KL26Z eval board, openSDA not working.

跳至解决方案
1,355 次查看
andrewparlane
Contributor IV

I have a FRDM-KL26Z eval board. I'm running the openSDA bootloader v1.11

From SDA_INFO.HTML:

Board Name is: FRDM-KL26Z

MicroBoot Kernel Version is: 1.05

Bootloader Version is: 1.11

Installed Application: PEMicro FRDM-KL26Z Mass Storage/Debug App

Application Version is: 1.14

I can boot into bootloader mode, and into the SDA application. The mass storage device appears. I see the expected contents.

However when I copy an srec from the precompiled examples in the quick start package from the FRDM-KL26Z freescale page (http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=FRDM-KL26Z&tid=vanFRDM-KL26Z) the openSDA led blinks a couple of times to indicate activity, and then goes solid. However nothing else happens. I've tried a few different applications, but no serial output / the RGB LED doesn't light up.

Opening laststat.txt before copying the binary says: "ready", after copying the binary and waiting 5s the file still says "ready". Power cycling the board has no effect either, other than the srec no longer is on the drive.

The demo app that came with the board worked fine, so it only stopped working after I reloaded the openSDA app as instructed in the quick start guide.

Anyone have any ideas?

Thanks

标记 (4)
0 项奖励
回复
1 解答
736 次查看
BlackNight
NXP Employee
NXP Employee

A common problem might be a virus scanner:

http://mcuoneclipse.com/2013/10/07/frdm-boards-not-responding-check-your-virus-scanner/

Or file manager/explorer extensions:

try to copy the file with the copy command from DOS Shell/command prompt.

在原帖中查看解决方案

0 项奖励
回复
3 回复数
737 次查看
BlackNight
NXP Employee
NXP Employee

A common problem might be a virus scanner:

http://mcuoneclipse.com/2013/10/07/frdm-boards-not-responding-check-your-virus-scanner/

Or file manager/explorer extensions:

try to copy the file with the copy command from DOS Shell/command prompt.

0 项奖励
回复
736 次查看
andrewparlane
Contributor IV

Hi, that worked great, thank you.

I just tried using command prompt, and it worked straight off. I have terracopy (http://codesector.com/teracopy) as an alternative to windows copy, so that's probably the problem.

0 项奖励
回复
736 次查看
BlackNight
NXP Employee
NXP Employee

Yes, TeraCopy and other such 'accelerators' are source of problems for such bootloaders.

0 项奖励
回复