KDS300 link problem with directory names

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

KDS300 link problem with directory names

ソリューションへジャンプ
570件の閲覧回数
dafodil
Contributor III

Hi,

 

I am trying to compile a project made with kds200, I used migration tool, and change arm libs.

 

I got this error below: the same as KDS200, the only solution I found: I make a copy and rename directory.

 

arm-none-eabi-g++: error: ./SDK/plaform/drivers/src/enet/fsl_enet_driver.o: No such file or directory

 

instead of:

arm-none-eabi-g++: error: ./SDK/platform/drivers/src/enet/fsl_enet_driver.o: No such file or directory

 

Do you know any other solution?

ラベル(1)
タグ(1)
0 件の賞賛
1 解決策
455件の閲覧回数
BlackNight
NXP Employee
NXP Employee

Is this on Windows?

If randomly characters get removed in the link phase (command line passed to the linker), then this is a sign that you execeed that magical 8192 character limit on Windows.

If this is the case, then I recommend that you have a read here:

Solving the 8192 Character Command Line Limit on Windows | MCU on Eclipse

which proposes to use an updated make utility.

I hope this helps,

Erich

元の投稿で解決策を見る

0 件の賞賛
2 返答(返信)
456件の閲覧回数
BlackNight
NXP Employee
NXP Employee

Is this on Windows?

If randomly characters get removed in the link phase (command line passed to the linker), then this is a sign that you execeed that magical 8192 character limit on Windows.

If this is the case, then I recommend that you have a read here:

Solving the 8192 Character Command Line Limit on Windows | MCU on Eclipse

which proposes to use an updated make utility.

I hope this helps,

Erich

0 件の賞賛
455件の閲覧回数
dafodil
Contributor III

Thanks Erich!!

0 件の賞賛