Error in services launch sequence

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Error in services launch sequence

2,914件の閲覧回数
dorotheebrunner
Contributor I

Hi,

 

I tried to get the TWR-K40X256 going with the Kinetis Design Studio.

 

First I needed to make an Bootloader Update. Everything went fine. After that the Debugger was found.

After that I tried to flash with the following configuration159973_159973.PNGflashconfig.PNG 

 

 

This failed with the an error.

160013_160013.PNGerror.PNG

 

Can anybody help me with this? I tried an Software Update. But it didn't work and I have no idea what is the problem. 

 

Thanks a lot.

Dorothee

ラベル(1)
0 件の賞賛
4 返答(返信)

1,917件の閲覧回数
dorotheebrunner
Contributor I

Hello Erich,

Thanks to you, I could solve this problem. There was another gdb in my PATH variable. Everything worked.

But when I started the application this morning again, I had another problem. The error message reads as follows

Error in final launch sequence
Failed to execute MI command:
-exec-run
Error message from debugger back end:
Error creating process C:/Users/brunner-beo/workspace.kds/Testskd/Debug/Testskd.elf, (error 193).
Error creating process C:/Users/brunner-beo/workspace.kds/Testskd/Debug/Testskd.elf, (error 193).

Maybe you can help me again.

0 件の賞賛

1,917件の閲覧回数
dorotheebrunner
Contributor I

Hi Erich,

I think the direction is right. I looked but the gdb is not running, and it is not started anyway.

So I searched for ist. But in the path "C:\Freescale\KDS_v3\Toolchain\arm-none-eabi\bin" there is no arm-none-eabi-gdb.exe like your link has discribed.

0 件の賞賛

1,917件の閲覧回数
BlackNight
NXP Employee
NXP Employee

Hi Dorothee,

the arm-none-eabi-gdb.exe should be in <kds>\Toolchain\bin

If it is not there, it might have been removed by a firewall or virus scan software?

Erich

0 件の賞賛

1,916件の閲覧回数
BlackNight
NXP Employee
NXP Employee

Hi Dorothee,

maybe gdb is already running? see https://mcuoneclipse.com/2015/05/18/gdb-client-and-server-unlocking-gdb/ 

I hope this helps,

Erich