Develop for KW20z in KDS (no BLE)

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Develop for KW20z in KDS (no BLE)

ソリューションへジャンプ
1,060件の閲覧回数
lokuate
Contributor III

I undestand NXP support for KW20/30/40 is limited to IAR at the moment because the BLE stack only works on IAR... but KW20 does not support BLE.

 

How can I develop for KW20 in KDS if it does not show on the Board/Processor selection window?

 

Thanks,

Carlos

ラベル(1)
1 解決策
892件の閲覧回数
ZhangJennie
NXP TechSupport
NXP TechSupport

Hi Carlos.

please install attached KW20 update to your KDS3.2. you should be able to find it in wizard list.

Installation:
  - Launch Eclipse
  - Choose the menu Help > Install New Software...
  - Press the Add... Button in the dialog
  - In the next dialog, choose the 'Archive...' button and browse for the KSDK_1.3.0_MKW20Z160xxx4_1.0.0_Eclipse_Update.zip installation package file
  - Then go through the guided update process
  - At the end, you are asked to restart Eclipse


Have a great day,
Jennie Zhang

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

元の投稿で解決策を見る

5 返答(返信)
892件の閲覧回数
lokuate
Contributor III

A-ha!!! That did it, thank you Jennie!

Carlos

892件の閲覧回数
ZhangJennie
NXP TechSupport
NXP TechSupport

You are welcome!

Jennie Zhang

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

892件の閲覧回数
ZhangJennie
NXP TechSupport
NXP TechSupport

Hi,

KDS3.2 can support KW20 without problem. here is the download link

Kinetis Design Studio Integrated Development Environment (IDE)|NXP 

pastedImage_2.png


Have a great day,
Jennie Zhang

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

892件の閲覧回数
lokuate
Contributor III

Thank you Jennie, Thank you for your help!

On my KDS 3.2.0 on a fresh install I get templates for projects with KW21, KW22 and KW24 not KW20 right off the bat, I presume I need to install additional patches, SDK or Connectivity kits to make it happen... While I have installed several I still don't see the template for KW20 projects can you please let me know what additions you installed for that?

Kindest Regards,

Carlos

0 件の賞賛
893件の閲覧回数
ZhangJennie
NXP TechSupport
NXP TechSupport

Hi Carlos.

please install attached KW20 update to your KDS3.2. you should be able to find it in wizard list.

Installation:
  - Launch Eclipse
  - Choose the menu Help > Install New Software...
  - Press the Add... Button in the dialog
  - In the next dialog, choose the 'Archive...' button and browse for the KSDK_1.3.0_MKW20Z160xxx4_1.0.0_Eclipse_Update.zip installation package file
  - Then go through the guided update process
  - At the end, you are asked to restart Eclipse


Have a great day,
Jennie Zhang

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------