GuiGuider 1.5.0 generated projects won't build in MCUXpresso

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

GuiGuider 1.5.0 generated projects won't build in MCUXpresso

ソリューションへジャンプ
1,735件の閲覧回数
PragmaLab
Contributor II

Hello all,

I updated to GuiGuider 1.5.0 some weeks ago and was happy to see that NXP kindly fixed the issues I wrote about earlier in this forum. Thanks for that.

Please note that ' out of the box'  generated MCUXpresso won't build in MCUXpresso due to missing lib-path includes:

  • cannot find -lopenh264
  • cannot find -lrlottie

To fix this, you need to have:

-L"<path to your project folder>\lib\x86"

in your buildsettings for the linker. Adding this path (for me) only works by adding the path using the 'Filesystem direcory' method. The 'Workspace'  method won't work (lib-subfolders are invisible in the project settings).

Breaking with the MCUXpresso project path and having to include libs from a \x86 (?) folder doesn't feel right. All for the sake of linking to H264 decoders and animation stuff which I don't even use in my GuiGuider project?

I suppose either this library search path needs to get included by default in the projects settings, or some option in GuiGuider should be introduced to disable the need for these 2 new features?

Furthermore the 1.5.0 manual seems missing?

kind regards

Rob

0 件の賞賛
返信
1 解決策
1,626件の閲覧回数
LiubinGong
NXP Employee
NXP Employee

Hello Pragmalab

  Thanks for your feedback, We know the reason for this problem, and it will be resolved in the next release. and workaround:  Create a new project based on your local project, which will work fine.

Best Regards

Liubin 

元の投稿で解決策を見る

0 件の賞賛
返信
5 返答(返信)
1,705件の閲覧回数
LiubinGong
NXP Employee
NXP Employee

Hello Pragmalab

   Thanks for your finding. In order to better fix the issue. Can you provide the following information clearly? 

  • host system environment
  • old project or newly created 
  • which platform

Thanks 

Liubin

0 件の賞賛
返信
1,637件の閲覧回数
PragmaLab
Contributor II

Sorry I wasn't clear on about the setup:

  • my GUI development takes place on a Windows 11 Pro (version22H2) PC
  • the project reported in the bug is an old (existing) project that was migrated to GuiGuider 1.5.0
  • the platform is an IMXRT1052 EVK board (using a 480 x 272 display)
  • I'm using MCUXpresso 11.6.1 with SDK 2.13.0

MCUXpresso does tricky  things when showing paths and files. It never represents the file-tree as being present on disc. In stead  it will present its  workspace file tree. I guess that makes that I can't add the lib path by choosing the Workspace option. 

Do we realy need the libs in the \x86 folder to build the (crossplatform) project? Aren't these libs meant for the simulator ?

 

kind regards,

Rob

 

0 件の賞賛
返信
1,718件の閲覧回数
CarlosGarabito
NXP TechSupport
NXP TechSupport

Thanks again to find that's bugs, we are checking it

0 件の賞賛
返信
1,636件の閲覧回数
PragmaLab
Contributor II

...forgot to mention. The 1.5.0 manual is available from within the IDE (Help -> User Guide) but on the GuiGuider NXP info page (https://www.nxp.com/design/software/development-software/gui-guider:GUI-GUIDER) only the 1.4.0 manual is available for download... (while the page announces the 1.5.0 version)

0 件の賞賛
返信
1,627件の閲覧回数
LiubinGong
NXP Employee
NXP Employee

Hello Pragmalab

  Thanks for your feedback, We know the reason for this problem, and it will be resolved in the next release. and workaround:  Create a new project based on your local project, which will work fine.

Best Regards

Liubin 

0 件の賞賛
返信