Debugging problem

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Debugging problem

1,818件の閲覧回数
JohnnyG
Contributor I
We are running CWide 5.7.0 build 1917 (what could be graciously called a vintage version, I guess?) and have an odd debugging problem.

Of several applications, we have one that refuses to be debugged. All of the settings in the project appear to be the same, with the exception of the target name. Both applications were written by the same guy, so I'm sure the project settings were cloned at the beginning.

With Application A, debugging starts up normally - i.e. the source code is displayed with the debug cursor on main(), and debugging can continue on apace.

With Application B (which has more variables declared in main() and has a much longer name, but otherwise quite similar), when the debug button is pressed, the code is pushed across the ethernet like normal, and the debugging window appears, but it disappears very quickly, as though it's set to execute rather than debug.

Is there a setting that we're missing? My cohort and I sat down and did a stare-and-compare of the target settings file, and the configuration is the same excepting the target name.

Anyone got any clues, hints, comments of derision, etc? We're pretty much stumped, and sick of debugging with printf statements.

Thanks in advance to anybody who can shed light.

JohnnyG

ラベル(1)
タグ(1)
0 件の賞賛
4 返答(返信)

299件の閲覧回数
J2MEJediMaster
Specialist I
By target name, are you talking about the name of the source file? That is, Application A's source file might be namedShortApp.c, versus Application B, whose source is named: AppWithAReallyReallyReallyLongName.c? Or are you talking about the project's target name, in CW's Target Settings Panel? If it's the source file, maybe the name is so long that something breaks in the transfer over the network? Have you tried shortening the name to see if that corrects the problem?

---Tom
0 件の賞賛

299件の閲覧回数
JohnnyG
Contributor I
In my case, the name of the C file is the name of the application. I'll try an experiment, but is 18 characters really a problem?

Thanks :smileywink:

0 件の賞賛

299件の閲覧回数
J2MEJediMaster
Specialist I
It shouldn't be a problem, I would think, but lacking any other information other than the file name being much longer, I have to suspect the file name's length is a culprit, somehow. If that doesn't work, you've going to have to provide more details, such as the system and OS that's generating the file, and the system and OS that's doing the debug.

---Tom
0 件の賞賛

299件の閲覧回数
JohnnyG
Contributor I
BTW, my cohort reports that the application IS actually just running, rather than stopping at main() for debugging. I'm hoping to look like I'm talking to myself here in a bit...

JohnnyG

0 件の賞賛