Debugger can't find MSL source

キャンセル
次の結果を表示 
表示  限定  | 次の代わりに検索 
もしかして: 

Debugger can't find MSL source

1,590件の閲覧回数
nspon
Contributor II
CW for ColdFire, v6.2. Is the debugger meant to be able to step into the MSL source? It switches to assembly every time I do so, it doesn't seem to be able to find the source. I have "Store Full Path Names" turned on, and the debugger finds the source of a library I have built just fine. I can't see what is different about MSL. I can successfully build the MSL library that I am using, and I have tried turning on "A6 stack frames", but to no avail...

I'm actually trying to understand alloc.c so I can figure out how to write free-memory and largest-block routines that scan the heap - if this has already been done somewhere I would love to know...

Thanks for any assistance,
Nigel
ラベル(1)
タグ(1)
0 件の賞賛
2 返答(返信)

333件の閲覧回数
CrasyCat
Specialist III

Hello

MSL library delivered with CodeWarrior for ColdFire 6.2 are generated without debug information. That is the reason you cannot see source code when you are stepping inside of a library function.

If you wish to be able to debug within the MSL library follows these steps:
  - Check which library files you are linking with your application (For Example 
    C_TRK_4i_CF_MSL.a)
  - Open the file {Install}\E68K_Support\msl\MSL_C\MSL_E68k\Project\MSL_C.CF.mcp
   - Activate the build target for the library you are using (for C_TRK_4i_CF_MSL.a
     it is TRK 4i ColdFire)
   - Click next to each if the folder in the column headed with the small green bug. When there is a dot there next to a source file, the compiler will generate debug info for the source file.
   - Rebuild the library.
   - Rebuild the application
You should be able to debug within alloc.c now.

CrasyCat

0 件の賞賛

333件の閲覧回数
nspon
Contributor II
Aaargh! Thanks, I missed that one entirely. Thats much better.
0 件の賞賛