Can't program M52259 demo board

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
已解决

Can't program M52259 demo board

跳至解决方案
1,624 次查看
cadet1620
Contributor I

Hello,

I'm using CW 7.1 build 14 with patch 7.1.2 build 11.

I've done the JM60 FW update per the 7.1.2 readme.

I've downloaded and installed MQX 3.3.

I can run the pre-programmed web_hvac demo.

I make a small change to the demo (change CD command to CDX) build and run.  Same old demo is running.  OK, I'm new to CW; obviously it doesn't automatically program the target -- it'd be nice if it told me the target was out of date, but whatever.

 

The flash programmer is initially configure for some incorrect target so I change it to use

52259 / Coldfire v2-v4 JM60 OSBDM

C:\Program Files\Freescale\CodeWarrior for ColdFire V7.1\ColdFire_Support\Initialization_Files\M52259DEMO.cfg

and set the flash config to CFM_MCF5225X_512

 

All attempts to blank-check / erase / program result in the error message

"ColdFire GDI Protocol Adapter : An error occurred while trying to write memory"

 

What am I doing wrong?

标签 (1)
标记 (1)
0 项奖励
1 解答
345 次查看
J2MEJediMaster
Specialist I

Have you tried the following:

 

1) Go the the Flash Programmer's Target Configuration panel. (Tools > Flash Programmer > Target Configuration.) From your post, it seems you are familiar with this panel.

 

2) Click on Load Settings.

 

3) Choose the file MCF52259_INTFLASH.xml. Click OK.

 

4) Go to the Erase / Blank Check  panel and try to erase the flash. If this works, it will erase the demo program in there, but that is what you are trying to do anyway.

 

If this does not work, I would suspect that you had a cabling problem.

 

---Tom

在原帖中查看解决方案

0 项奖励
2 回复数
346 次查看
J2MEJediMaster
Specialist I

Have you tried the following:

 

1) Go the the Flash Programmer's Target Configuration panel. (Tools > Flash Programmer > Target Configuration.) From your post, it seems you are familiar with this panel.

 

2) Click on Load Settings.

 

3) Choose the file MCF52259_INTFLASH.xml. Click OK.

 

4) Go to the Erase / Blank Check  panel and try to erase the flash. If this works, it will erase the demo program in there, but that is what you are trying to do anyway.

 

If this does not work, I would suspect that you had a cabling problem.

 

---Tom

0 项奖励
345 次查看
Ing_Comunicacio
Contributor I

Hello, when I do what you indicate in the text box, I get a message of no connection. You can help me.

thanks.

0 项奖励