U-Boot Debug using CodeWarrior for QorIQ LS series – ARM V7 ISA

Showing results for 
Search instead for 
Did you mean: 

U-Boot Debug using CodeWarrior for QorIQ LS series – ARM V7 ISA

No ratings

U-Boot Debug using CodeWarrior for QorIQ LS series – ARM V7 ISA

U-Boot Debug using CodeWarrior for QorIQ LS series – ARM V7 ISA

Labels (1)


I have a problem on loading u-boot into our bareboard.

I have a customized LS1021A bareboard, how could I load u-boot into this board?

I compiled a u-boot and tried to attach it by a CodeWarrior TAP, but I always got some JTAG configuration failure.

     Error launching LS1021AQDS_Debug_LS1021AQDS_Attach

     CCSProtocolPlugin : Failed to correctly configure the JTAG chain

Is an on-board programmed u-boot necessary? Or I should change the target initialization file too?


Usually the " Failed to correctly configure the JTAG chain" is generated by the missing of RCW or the wrong configuration of the switches .



I have another question, I try to boot from the QSPI flash, I should use ls1021aqds_spi to compile my u-boot, right? Should I also need to build a SPL?

Indeed, to boot from qspi you should used ls1021aqds_spi to compile u-boot.

Hi Adrian,

I have another question: Can I debug the u-boot that boots up from NAND by this way?


I didn't try to debug uboot from NAND, but should be the same. Let me know if doesn't work and I can take a look.


Hi Adrian,

I tried it on a bare board, it doesn't work. Maybe the reason is no u-boot in the NAND flash.

I have programmed a RCW file into the NAND flash, so I can gain the JTAG control.


Yes, this is the reason. You have to flash a u-boot with spd-pbl image into the NAND to have all is necessary (rcw, pbi, uboot) for NAND boot.


Hi Adrian,

I still have troubles in debuging the NAND boot u-boot.

The NAND boot file "u-boot" is different from the NOR boot file "u-boot", there is another "SPL" part.

How could I debug the NAND boot file?


Do you use LS1021AQDS board? If yes, could you provide your switches settings? Also, did you use u-boot-with-spl-pbl-ls1021aqds_nand.bin?


Hi Adrian,

I'm working on a custom board now. I have made a working u-boot for my board.

But still I cannot debug the file "u-boot" normally,

While I reset it(Figure 10), what I get is different from Figure 11, there is no place to set the source code location.

Here is the message:

No source available for "0x00001EC0 (0x00001EC0)() "

I just try on my QDS board and after reset without init, CW will prompt for source location. Could you please file on u-boot elf and provide the results.

My u-boot elf for nand boot looks like below:

$ file u-boot

u-boot: ELF 32-bit LSB shared object, ARM, version 1 (SYSV), dynamically linked (uses shared libs), not stripped

Hi Adrian,

My file information is the same, but while I reset without any init file, here is what's inside the debug window:

100 of_read_number() fdt_support.c:1397 0x00000000

99 of_read_number() fdt_support.c:1397 0x00000000

98 of_read_number() fdt_support.c:1397 0x00000000


3 of_read_number() fdt_support.c:1397 0x00000000

2 of_read_number() fdt_support.c:1397 0x00000000

1 of_read_number() fdt_support.c:1397 0x00000000

If I press "Step Over"/ "Step Into", it will prompt

No source available for "0x00001EC0 (0x00001EC0)() "

If I choose Resume/Step Return, it won't prompt anything and I can only Pause or Terminate it.

Besides, I have tried to debug linux kernel and it didn't prompt for source location either.

I delete the whole workspace and redo those steps, but it doesn't work.

Did you still have this issue? What CW version you are using?

Version history
Revision #:
1 of 1
Last update:
‎06-11-2014 01:31 AM
Updated by: