Subversion (SVN) Codewarrior 10

cancel
Showing results for 
Search instead for 
Did you mean: 

Subversion (SVN) Codewarrior 10

3,741 Views
samueldionisiod
Contributor II

Hello,

I know with is possible to install the subversion in codewarrior 10, if yes how?

Thanks

Samuel

9 Replies

673 Views
samueldionisiod
Contributor II

Problema resolvido com o tutorial..

Obrigado.

SAmuel

0 Kudos

673 Views
BlackNight
NXP Employee
NXP Employee

Attached is a presentation I use to introduce version control in general, plus how to install Subclipse in Eclipse/CodeWarrior for MCU 10.x.

I hope this is useful,

Erich

673 Views
Eowyn
Contributor II

Great presentation @Erich, thanks.

0 Kudos

673 Views
JimDon
Senior Contributor III

Erich,

Nice write up.

I wish you make a requirement to use Source Control to pass your courses. Too many grads not only are un-familiar with it, they don't even understand the why from a pragmatic point of view. e.g. Lose you code base once and you start using SCM....

--Jim

0 Kudos

673 Views
BlackNight
NXP Employee
NXP Employee

Jim,

thanks :-).

And yes, it *is* a requirement to pass the course. During the course teams develop a motor control application with a wireless control unit. Without a version control system that would be very, very difficult, especially working in teams on the same source base/etc.

Erich

0 Kudos

673 Views
LuisCasado
NXP Employee
NXP Employee

Hi,

have a look to the attached presentation. I hope this helps.

Bets Regards,

Luis

673 Views
Eowyn
Contributor II

On Lab 5 - Using version control.pdf I found a dead link:

http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/ does not exist, and at polarion site I only found paid software (with 1 month trial). 

So I could not finish the installation.

0 Kudos

673 Views
BlackNight
NXP Employee
NXP Employee

I recommend to use Subclipse instead (http://subclipse.tigris.org). Details are in the SW02a SVN.pdf posted below.

Anyway, I pretty much have switched to Git now (I only use SVN for legacy projects).

If you are using CW MCU10.4, then this one helps you with eGit: Installing eGit in Eclipse and CodeWarrior for MCU10.4 | MCU on Eclipse

0 Kudos

673 Views
obidon
Contributor III

Samuel,

I am using subversion with CodeWarrior 10.2. Install the Subclipse package. Click "Help" "Install new software" Click "Add" to add the site URL "http://subclipse.tigris.org/update_1.8.x" You can then install the conponents "Subclipse" and "Subversion client adapter".