Migrating project from CW 6.2 to CW 10

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Migrating project from CW 6.2 to CW 10

Jump to solution
4,162 Views
kavshi
Contributor II

1) Can we directly migrate the project from CodeWarrior Development Studio for ColdFire Architectures v6.2 to CW10/Eclipse? If not what is the best method of migrating? Do i need to upgrade to higher version of CW and then to CW 10?

2) I tried migrating using Codewarrior project impoter as suggested in the fourm Importing your CodeWarrior projects but am getting error, below is the description

 

For our project we are using CodeWarrior Development Studio for ColdFire Architectures v6.2 for microcontroller MCF5485. We want to migrate to Eclipse Codewarrior(C language, Version: 1.0.0 ,Build Id: b15_2105-A22). When I try to migrate *.mcp using Codewarrior project impoter am getting error. Error: unsupported settings panel version in Release. Can anybody help me to understand why this error is coming and is it right way to migrate? Please let me know if we have any other way to migrate.

 

98880_98880.pngerror.png

 

Thanks in Advance

Labels (1)
0 Kudos
1 Solution
2,865 Views
kavshi
Contributor II

I will get back to you on this.

Once again thanks for the help

View solution in original post

0 Kudos
8 Replies
2,865 Views
trytohelp
NXP Employee
NXP Employee

Hi,

For me you're using the last version CW for MCU V10.6.

The importer is not compatible with Coldfire.

This importer is working for DSC processors only.

CW for Coldfire V6.2 is an old version.

This is the roadmap:

    CW for Coldfire V6.2

    CW for Coldfire V7.0

    CW for Coldfire V7.1

    CW for Coldfire V7.2      -> this is the last version based on classic IDE

    CW for MCU V10.0          -> this is the 1st version based on Eclipse

          ...

    CW for MCU V10.6.4

There are some improvements between V6.2 to V7.2.

Attached you will find 2 AN giving some information.

The CodeWarrior importer was provided on CW for MCU V10.0, V10.1 and V10.2.

The importer delivered on recent version as CW for MCU V10.6.4 is valid for DSC project only.

On older MCU V10.x versions, the importer was designed to import project running under last classic version - for each product:

    - CW for MCU V6.3,

    - CW for Coldfire V7.2,

    ...

If you're using an older version you can have some problems.

Depending of the project (complex one) you can have problem too.

To avoid all these problem the importer was discontinue since MCU V10.3

How to import classic project to Eclipse ?

There are 2 ANs explaining the process depending of the architecture used.

          AN4727, Import project from CW classic to CW MCU v10 4 CodeWarrior for Microcontrollers v10.4

                        http://cache.freescale.com/files/soft_dev_tools/doc/app_note/AN4727.pdf

          AN4104, Converting ColdFire Projects to CodeWarrior Development Studio for Microcontrollers V10.0

                        http://cache.freescale.com/files/soft_dev_tools/doc/app_note/AN4104.pdf


Have a great day,
Pascal
Freescale Technical Support
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
2,865 Views
kavshi
Contributor II

Thanks a lot Pascal for the detailed and quick response.

Now am clear that we will not be able to use importer provided in eclipse.

I will go through the documents sent by you and migrate the project.

I needed few more clarification
1) You have specified - "There are some improvements between V6.2 to V7.2", do we need to do these improvements and then migrate to Eclipse?

2)
Document attached TN 268 -> talks about migrating from 7.1 to 7.2
Document attached TN 256 -> talks about migrating from 6.4 to 7.0
We are using 6.2 version, do we need to migrate to v7.2 and then to eclipse 10.x, if so is there any document which explains migrating from 6.2 to 7.2?

3) As we are migrating to eclipse wanted to know which version of Eclipse would be better?

4) Can we use the license of CW for Coldfire V6.2 to Eclipse?

0 Kudos
2,865 Views
trytohelp
NXP Employee
NXP Employee

See below more info ...

1) Hum ... difficult to say.

    It could be more easy to move to the V7.2 and be sure the application is running on the last classic version before to move on Eclipse.

    Now it's possible o move directly to the MCU V10.6.4 (last version) directly.

    The complexity of your project is the key point here.

    Personally I recommend to move your project on V7.2.

    After to have tested the application is running fine on this version you can move it to MCU V10.6.4.

  

2) Don't think there are big differences between V6.0 to V6.4 excepted general tools improvement.

    You can apply the 2 TNs on your project and move it on V7.2.

    It should work.

3) I recommend to use the last version which is MCU V10.6.4 (+ patch V10.6.5 proposed automatically).

    Now you can use an another version as MCU V10.2 which included the importer feature.

    Again the importer worked for standard project but not for complex one.

    Better to follow the AN provided in previous message.

4) License ...

The installer includes an evaluation license file (30 days).

Unfortunately the V6.x license file is running on V6.x tools only.

The V7.2 requires a new license file and MCU V10.x another one too.

This is not free of charge and I can not give you a price.

This depends is you've already a registration which is not too old.

The registration, Part number is defined as Examples:

                CWP-PRO-NL_1-387604471

                FSL-13d9-3f41-13b7-03b3-102c-c8

                AB693-1DC57-2AB67-E014C

Sometimes the registration is encrypted in the license.dat file.

There are 4 Suites which I can resume by

    - Special (Free of charge): code size limited

    - Basic: code size limited

    - Standard : C not limited

    - Prof: C/C++ and RTOS

For details, please have a look to:

    CodeWarrior Suites (Bas, Stand, Pro)|Freescale

   
Have a great day,
Pascal
Freescale Technical Support
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
2,865 Views
kavshi
Contributor II

We are using MQX 2.5 version with codewarrior 6.2. Importing project to eclipse 10 is linked to MQX version or it is independent of MQX version?

Thanks in Advance

0 Kudos
2,865 Views
trytohelp
NXP Employee
NXP Employee

Hi,

MQX is linked to development tool version used.

By default when a new version of CodeWarrior was released, a new MQX version was released too.

If you want to move to CW for MCU v10.6.4 which is the last version I recommend to move on last MQX versions too.

Does the older MQX version could work on MCU v10.6.4 ?

It could ... but I don't think it was tested.

Have a great day,
Pascal
NXP Technical Support
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
2,865 Views
kavshi
Contributor II

I will go for migrating to 7.2 and then 10.6.4 as per your suggestion.

We have already purchased Prof CW for 6.2V with floating license. Can't we use same license for the 7.2V and10.6.4?

0 Kudos
2,865 Views
trytohelp
NXP Employee
NXP Employee

Unfortunately the V6.2 license file is valid for all V6.x versions only.

V7.2 requires a new license file for V7.x versions.

And Eclipse is using another license file too.

I can not give a cost to upgrade your license file from V6.2 to V10.6.4.

If your license is associated to a new registration a renewal will be enough.

However if you don't have a new registration code you need to purchase a new registration.

The cost is defined at the links:

    Suite Purchasing Model Options|Freescale

    http://cache.freescale.com/files/soft_dev_tools/doc/fact_sheet/950-00437.pdf

If you want more info, I need to know the suite you're using.

Part number is defined as Examples:

                CWP-PRO-NL_1-387604471

                FSL-13d9-3f41-13b7-03b3-102c-c8

                AB693-1DC57-2AB67-E014C

In another way, in recent license file, the info is coded in the license file too.

Can you provide us your license.dat file used ?

It should be better to continue via a SR.

I will create a SR and will re-contact you soon.

Have a great day,
Pascal
Freescale Technical Support
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
2,866 Views
kavshi
Contributor II

I will get back to you on this.

Once again thanks for the help

0 Kudos