CW for Power Architectures 8.8 - Processor 826x is not supported by the current set of licenses

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

CW for Power Architectures 8.8 - Processor 826x is not supported by the current set of licenses

204 Views
gonzob
Contributor II

Sorry for double-posting; I just realized this is probably the right forum. Admins/Mods feel free to delete my other topic: https://community.nxp.com/t5/PowerQUICC-Processors/CW-for-Power-Architectures-8-8-Processor-826x-is-...

 

I'm currently running the eval version of CodeWarrior for Power Architectures 8.8.
Installation went smooth without errors. I decided to start as I always do, by compiling the various examples included.

Everything worked, all examples compile without issues. The problem happens when I go to: Edit > Embedded PPC 8260 C Settings > Code Generation > EPPC Processor
At this point, I get one of the below errors:

gonzob_0-1711477974061.png

This happens both with the evaluation license generated during installation as well as with the one downloaded from the NXP website.

Is 8260 separately licensed? I'm surprised this is only affecting this settings panel.
Or is 8260 not supported and was included by mistake?

TIA

0 Kudos
1 Reply

132 Views
yipingwang
NXP TechSupport
NXP TechSupport

I installed CodeWarrior 8.8 with evaluation license on a new PC, the function which you described worked normally, please refer to my attached screenshot.

 

You encountered this problem, I suspect this is because your evaluation CodeWarrior license expired.

 

You could install CodeWarrior 8.8 on a new PC or create a new case to ask the license team to extend your evaluation license for CodeWarrior 8.8.

 

Also you could purchase a valid CodeWarrior license from https://www.nxp.com/design/design-center/software/development-software/codewarrior-development-tools...

0 Kudos