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As there is not a New MQX Project Wizard it is necessary to create a project from scratch. This document 

explains 2 ways to create a new MQX for KSDK project.  

- Create a copy from an example project. 

o IMPORTANT: The clue is to edit all the include paths to make the project independent from 

its original location in the Examples folder. 

- Create a new project from scratch and add all the necessary files and edit all the necessary settings 

o At the end this project must look the same as a copy of an example. 

 

The tools used in this guide are KSDK1.2, KDS3.0 and FRDM-K64.  
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1 Requirements – DO NOT Skip 

1.1 Install KDS (Kinetis Design Studio), you can download from www.freescale.com/kds   

1.2 Install KSDK (Kinetis Software Development Kit), you can download from 

www.freescale.com/ksdk   

1.3 Install ‘KSDK_1.2.0_Eclipse_Update’ you can find the update in 

‘C:\Freescale\KSDK_1.2.0\tools\eclipse_update’. The instruction to make the updates are described in 

chapter 2 and 2.1 of ‘C:\Freescale\KSDK_1.2.0\doc\rtos\mqx\MQX RTOS IDE Guides\MQX-KSDK-KDS-

Getting-Started.pdf’ 

1.4 It is necessary to build the following libraries: 

1.4.1 Platform Library for MQX, ‘libksdk_platform_mqx.a’ 

• This project is located in ${KSDK_PATH}/lib/ksdk_mqx_lib/kds/<mcu> 

1.4.2 MQX Library, ‘lib_mqx.a’ 

• This project is located in “${KSDK_PATH}/rtos/mqx/mqx/build/kds/mqx_<board>” 

1.4.3 MQX Standard Library, ‘lib_mqx_stdlib.a’ 

• This project is located in “${KSDK_PATH}/rtos/mqx/mqx_stdlib/build/kds/mqx_stdlib_<board>” 

NOTE: For information about building KSDK and MQX libraries in KDS please see chapter ‘3 Building MQX 

RTOS example and libraries’ of ‘MQX-KSDK-KDS-Getting-Started.pdf’ located in MQX for KSDK 

installation path C:\Freescale\KSDK_1.2.0\doc\rtos\mqx\MQX RTOS IDE Guides 
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2 Create a Copy from an Example Project

2.1 Go to menu File > Import and browse for the 

C:\Freescale\KSDK_1.2.0\rtos\mqx\mqx

Please refer to chapter ‘3 Building MQX 

Started.pdf’ for instructions to import a project.

C:\Freescale\KSDK_1.2.0\doc\rtos\mqx

2.2 Once the hello_frdmk64f 

using Ctrl + C and Ctrl + V keys and you will be prompted to set a new name.

 

 

Alternately you can right click on the project and select 
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Create a Copy from an Example Project 

and browse for the hello_frdmk64f located in the following path:

mqx\examples\hello\build\kds\hello_frdmk64f 

3 Building MQX RTOS example project and libraries’ of ‘MQX-KSDK

for instructions to import a project. This file is located in 

mqx\MQX RTOS IDE Guides 

 example is imported into the workbench you can just copy

keys and you will be prompted to set a new name. 

Alternately you can right click on the project and select ‘Copy’ and ‘Paste’ from context menu.

Freescale Semiconductor

located in the following path: 

KSDK-KDS-Getting-

you can just copy-paste it 

 

from context menu. 
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2.3 The new project will be created

project’s location is your current workspace and the project’s include paths are relative to the original location 

of the hello_frdmk64f example. 

 

2.4 Go to menu Project > Properties > C

Includes and delete all the paths. These paths are not used in this example.
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created and many warnings will be shown. This is because the new 

project’s location is your current workspace and the project’s include paths are relative to the original location 

 

menu Project > Properties > C/C++ Build > Settings > Cross ARM GNU

These paths are not used in this example. 

Freescale Semiconductor

and many warnings will be shown. This is because the new 

project’s location is your current workspace and the project’s include paths are relative to the original location 

 

Settings > Cross ARM GNU Assembler > 
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2.5 Go to menu Project > Properties > C/C++ Build > Settings > Cross

fix all the paths by setting absolute paths. You can copy and paste the paths below.

It is possible to add all the paths at the same time, please refer to the post in the following link:

http://mcuoneclipse.com/2014/12/23/adding

 

 

 

   

 

 

 

 

 

 

 

 

 

 

 

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\examples

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx
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menu Project > Properties > C/C++ Build > Settings > Cross ARM C Compiler

s. You can copy and paste the paths below. 

It is possible to add all the paths at the same time, please refer to the post in the following link:

tp://mcuoneclipse.com/2014/12/23/adding-multiple-include-paths-to-build-settings-in-eclipse/

mqx\config\mcu\MK64F12 

mqx\config\board\frdmk64f 

mqx\config\common 

mqx\mqx\source\include 

mqx\mqx\source\bsp 

platform\utilities\src 

platform\utilities\inc 

examples\frdmk64f 

platform\devices\MK64F12\startup 

platform\devices\MK64F12\include 

platform 

platform\devices 

platform\CMSIS\Include 

platform\hal\inc 

platform\drivers\inc 

platform\drivers\src\mpu 

platform\drivers\src\uart 

platform\utilities\inc 

platform\osa\inc 

platform\system\inc 

mqx\lib\frdmk64f.kds\debug\config 

mqx\lib\frdmk64f.kds\debug\mqx 

mqx\lib\frdmk64f.kds\debug\mqx_stdlib 

Freescale Semiconductor

Compiler > Includes and 

It is possible to add all the paths at the same time, please refer to the post in the following link: 

eclipse/  
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2.6 Go to menu Project > Properties > C/C++ Build > Settings > Cross 

the linker file path by setting the absolute path. 

C:\Freescale\KSDK_1.2.0\platform\devices

NOTE: If you plan to edit the linker file it is strongly recommended to make a copy of the .ld file because all the 

new projects and example projects will be affected by the .ld changes.

2.7 Go to menu Project > Properties > C/C++ 

all the Libraries search paths by setting the absolute paths. 

It is possible to add all the paths at the same time, please refer to the post in the following link:

http://mcuoneclipse.com/2014/12/23/adding

 

 

 

 

C:\Freescale\KSDK_1.2.0\lib\ksdk_mqx_lib

C:\Freescale\KSDK_1.2.0\rtos\mqx\lib

C:\Freescale\KSDK_1.2.0\rtos\mqx\lib
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Properties > C/C++ Build > Settings > Cross ARM C Linker

the linker file path by setting the absolute path.  

devices\MK64F12\linker\gcc\ MK64FN1M0xxx12_flash.ld

it is strongly recommended to make a copy of the .ld file because all the 

new projects and example projects will be affected by the .ld changes. 

Project > Properties > C/C++ Build > Settings > Cross ARM C Linker > 

paths by setting the absolute paths.  

It is possible to add all the paths at the same time, please refer to the post in the following link:

http://mcuoneclipse.com/2014/12/23/adding-multiple-include-paths-to-build-settings-in-eclipse/

ksdk_mqx_lib\kds\K64F12\debug 

lib\frdmk64f.kds\debug\mqx_stdlib 

lib\frdmk64f.kds\debug\mqx 

Freescale Semiconductor

Linker > General and fix 

MK64FN1M0xxx12_flash.ld 

 

it is strongly recommended to make a copy of the .ld file because all the 

Linker > Libraries and fix 

It is possible to add all the paths at the same time, please refer to the post in the following link: 

eclipse/  
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2.8 Now the new project is completely self

this point make sure that de KSDK update is installed, please refer to step 1.3 in this documen

 

  

Creating a New MQX RTOS for KSDK Project in KDS 

Freescale Semiconductor

 

Now the new project is completely self-dependent and ready to run. If you have any problem at 

this point make sure that de KSDK update is installed, please refer to step 1.3 in this documen

Freescale Semiconductor

 

If you have any problem at 

this point make sure that de KSDK update is installed, please refer to step 1.3 in this document. 
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3 Create a new MQX RTOS for KSDK

3.1 Go to menu File > New > Kinetis Design Studio Project

 

3.2 Write a name for your project and click 

 

3.3 Select your target and click ‘
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KSDK Project from Scratch 

menu File > New > Kinetis Design Studio Project. 

Write a name for your project and click ‘Next’. 

 

and click ‘Next’. 
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3.4 Select ‘KSDK 1.2.0’ to include KSDK support and be sure that the SDK Absolute Path is correct. 

Then click ‘Finish’. If you have any problem at this point make sure that de KSDK update is installed, please 

refer to step 1.3 in this document 

 

  

Creating a New MQX RTOS for KSDK Project in KDS 

Freescale Semiconductor

to include KSDK support and be sure that the SDK Absolute Path is correct. 

If you have any problem at this point make sure that de KSDK update is installed, please 
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to include KSDK support and be sure that the SDK Absolute Path is correct. 

If you have any problem at this point make sure that de KSDK update is installed, please 
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3.5 The easiest way to add all th

the virtual folders structure of an MQX for KSDK example

You can simply copy-paste this folder structure from the ‘

the following steps explain how to create this structure 

 

3.6 Erase ‘Project_Settings’ and 

folders with the following names. 

• BSP_Files 

• Config_Files 

• Debug_Console 

• KSDK_Files 
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The easiest way to add all the KSDK and MQX support required for a new project is to 

the virtual folders structure of an MQX for KSDK example. 

paste this folder structure from the ‘hello_frdmk64f’ example project. 

llowing steps explain how to create this structure manually. 

 

and ‘SDK’ folders which are created in the default project. Then c

Freescale Semiconductor

a new project is to duplicate 

example project. In this guide 

folders which are created in the default project. Then create 4 
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NOTE: You can either create physical folders or virtual folders. 

project’s name and select New > Folder. In the New Folder window click 

Folder’. 

3.7 Then create a sub-folder inside 
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an either create physical folders or virtual folders. To create a virtual folder right click in the 

. In the New Folder window click ‘Advanced’ button and select 

 

inside ‘Config_Files’ named ‘Common’. 

 

Freescale Semiconductor

To create a virtual folder right click in the 

button and select ‘Virtual 
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3.8 Add the following files to each of the folders. You can just drag and drop from Windows Explorer. 

• BSP_Files 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\mqx\source\bsp\bsp_config.h 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\mqx\source\bsp\bsp.h 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\mqx\source\bsp\init_bsp.c 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\mqx\source\bsp\mqx_main.c 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\mqx\source\include\mqx.h 

• Config_Files 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\config\mcu\MK64F12\mqx_sdk_config.h 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\config\board\frdmk64f\user_config.h 

• Debug_Console 

o C:\Freescale\KSDK_1.2.0\platform\utilities\src\fsl_debug_console.c 

o C:\Freescale\KSDK_1.2.0\platform\utilities\inc\fsl_debug_console.h 

o C:\Freescale\KSDK_1.2.0\platform\utilities\src\fsl_misc_utilities.c 

o C:\Freescale\KSDK_1.2.0\platform\utilities\src\print_scan.c 

o C:\Freescale\KSDK_1.2.0\platform\utilities\src\print_scan.h 

• KSDK_Files 

o C:\Freescale\KSDK_1.2.0\examples\frdmk64f\board.c 

o C:\Freescale\KSDK_1.2.0\examples\frdmk64f\board.h 

o C:\Freescale\KSDK_1.2.0\examples\frdmk64f\gpio_pins.c 

o C:\Freescale\KSDK_1.2.0\examples\frdmk64f\gpio_pins.h 

o C:\Freescale\KSDK_1.2.0\examples\frdmk64f\pin_muc.c 

o C:\Freescale\KSDK_1.2.0\examples\frdmk64f\pin_mux.h 

• Common 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\config\common\lite_config.h 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\config\common\mqx_cnfg.h 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\config\common\small_ram_config.h 

o C:\Freescale\KSDK_1.2.0\rtos\mqx\config\common\verif_enabled_config.h 

NOTE: If you are using physical folders you will be asked whether you want to copy or link the file, in this 

example physical folders were created and the files are copied into the project. 
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3.9 Go to menu Project > Properties > C/C++ Build

If you created physical folders erase all the content and replace it with the following paths. You can copy and 

paste the paths below. 

It is possible to add all the paths at once, please refer to the post in t

http://mcuoneclipse.com/2014/12/23/adding

 

 

 

   

 

 

 

 

 

 

 

 

 

 

../BSP_Files 

../Config_Files 

../Config_Files/Common 

../Debug_Console 

../KSDK_Files 

C:\Freescale\KSDK_1.2.0\rtos\mqx\mqx

C:\Freescale\KSDK_1.2.0\platform\devices

C:\Freescale\KSDK_1.2.0\platform\devices

C:\Freescale\KSDK_1.2.0\platform 

C:\Freescale\KSDK_1.2.0\platform\devices

C:\Freescale\KSDK_1.2.0\platform\CMSIS

C:\Freescale\KSDK_1.2.0\platform\hal\

C:\Freescale\KSDK_1.2.0\platform\drivers

C:\Freescale\KSDK_1.2.0\platform\drivers

C:\Freescale\KSDK_1.2.0\platform\drivers

C:\Freescale\KSDK_1.2.0\platform\utilities

C:\Freescale\KSDK_1.2.0\platform\osa\

C:\Freescale\KSDK_1.2.0\platform\system

C:\Freescale\KSDK_1.2.0\rtos\mqx\lib\

C:\Freescale\KSDK_1.2.0\rtos\mqx\lib\

C:\Freescale\KSDK_1.2.0\rtos\mqx\lib\
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menu Project > Properties > C/C++ Build > Settings > Cross ARM C Compiler

erase all the content and replace it with the following paths. You can copy and 

It is possible to add all the paths at once, please refer to the post in the following link: 

http://mcuoneclipse.com/2014/12/23/adding-multiple-include-paths-to-build-settings-in-eclipse/

mqx\source\include 

devices\MK64F12\startup 

devices\MK64F12\include 

devices 

CMSIS\Include 

\inc 

drivers\inc 

drivers\src\mpu 

vers\src\uart 

utilities\inc 

\inc 

system\inc 

\frdmk64f.kds\debug\config 

\frdmk64f.kds\debug\mqx 

\frdmk64f.kds\debug\mqx_stdlib 

Freescale Semiconductor

Compiler > Includes. 

erase all the content and replace it with the following paths. You can copy and 

eclipse/  
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If you created virtual folders erase all the content and replace it with the following paths. You can copy and 

paste the paths below. 

It is possible to add all the paths at once

http://mcuoneclipse.com/2014/12/23/adding

 

 

 

   

 

 

 

 

 

 

 

 

 

 

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\examples

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\platform

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx

C:\Freescale\KSDK_1.2.0\rtos\mqx
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erase all the content and replace it with the following paths. You can copy and 

once, please refer to the post in the following link: 

http://mcuoneclipse.com/2014/12/23/adding-multiple-include-paths-to-build-settings-in-eclipse/

mqx\config\mcu\MK64F12 

mqx\config\board\frdmk64f 

mqx\config\common 

mqx\mqx\source\include 

mqx\mqx\source\bsp 

platform\utilities\src 

platform\utilities\inc 

examples\frdmk64f 

platform\devices\MK64F12\startup 

platform\devices\MK64F12\include 

platform 

platform\devices 

platform\CMSIS\Include 

platform\hal\inc 

platform\drivers\inc 

platform\drivers\src\mpu 

platform\drivers\src\uart 

platform\utilities\inc 

platform\osa\inc 

platform\system\inc 

mqx\lib\frdmk64f.kds\debug\config 

mqx\lib\frdmk64f.kds\debug\mqx 

mqx\lib\frdmk64f.kds\debug\mqx_stdlib 

Freescale Semiconductor

erase all the content and replace it with the following paths. You can copy and 

eclipse/  
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3.10 Go to menu Project > Properties > C/C++ Build > Settings > Cross 

fix the linker file path by setting the absolute path. 

C:\Freescale\KSDK_1.2.0\platform\devices

NOTE: If you plan to edit the linker file it is strongly recommended to make a copy o

new projects and example projects will be affected by the .ld changes.
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menu Project > Properties > C/C++ Build > Settings > Cross ARM C++ Linker > General

fix the linker file path by setting the absolute path.  

devices\MK64F12\linker\gcc\MK64FN1M0xxx12_flash.ld

If you plan to edit the linker file it is strongly recommended to make a copy of the .ld file because all the 

new projects and example projects will be affected by the .ld changes. 

Freescale Semiconductor

Linker > General and 

MK64FN1M0xxx12_flash.ld 

 

f the .ld file because all the 
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3.11 Go to menu Project > Properties > C/C++ 

add all the Libraries search paths.  

It is possible to add all the paths at the same time, please refer to the post in the following link:

http://mcuoneclipse.com/2014/12/23/adding

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

ksdk_platform_mqx 

_mqx_stdlib 

_mqx 

gcc 

c 

supc++ 

m 

nosys  

 

C:\Freescale\KSDK_1.2.0\lib\ksdk_mqx_lib

C:\Freescale\KSDK_1.2.0\rtos\mqx\lib

C:\Freescale\KSDK_1.2.0\rtos\mqx\lib

Creating a New MQX RTOS for KSDK Project in KDS 

Freescale Semiconductor

Project > Properties > C/C++ Build > Settings > Cross ARM C++ Linker > 

dd all the paths at the same time, please refer to the post in the following link:

http://mcuoneclipse.com/2014/12/23/adding-multiple-include-paths-to-build-settings-in-eclipse/

ksdk_mqx_lib\kds\K64F12\debug 

lib\frdmk64f.kds\debug\mqx_stdlib 

lib\frdmk64f.kds\debug\mqx 

Freescale Semiconductor

Linker > Libraries and 

dd all the paths at the same time, please refer to the post in the following link: 

eclipse/  

 



 

 

 

Creating a New 

18 

3.12 Go to menu Project > Properties > C/C++ Build > Settings > Cross ARM C++ Linker > 

Miscellaneous and add all the Libraries with their full paths. 

It is possible to add all the paths at the same time, please refer to the post in the following link:

http://mcuoneclipse.com/2014/12/23/adding

 

 

 

 

 

 

 

 

  

C:\Freescale\KSDK_1.2.0\lib\ksdk_mqx_lib

C:\Freescale\KSDK_1.2.0\rtos\mqx\lib

C:\Freescale\KSDK_1.2.0\rtos\mqx\lib
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menu Project > Properties > C/C++ Build > Settings > Cross ARM C++ Linker > 

and add all the Libraries with their full paths.  

paths at the same time, please refer to the post in the following link:

http://mcuoneclipse.com/2014/12/23/adding-multiple-include-paths-to-build-settings-in-eclipse/

ksdk_mqx_lib\kds\K64F12\debug\libksdk_platform_mqx.a

lib\frdmk64f.kds\debug\mqx_stdlib\lib_mqx_stdlib.a

lib\frdmk64f.kds\debug\mqx\lib_mqx.a 

Freescale Semiconductor

menu Project > Properties > C/C++ Build > Settings > Cross ARM C++ Linker > 

paths at the same time, please refer to the post in the following link: 

eclipse/  

 

libksdk_platform_mqx.a 

tdlib.a 
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3.13 At this point you may see some warnings

settings for C and C++ and we have not fixed the C++

menu Project > Properties > C/C++ Build > Settings > Cross

paths. 

 

 

3.14 Go to menu Project > Properties > C/C++ Build > Settings > Cross ARM 

Preprocessor and add the following definitions.

 

 

 

 

  

CPU_MK64FN1M0VMD12=1 

FSL_RTOS_MQX=1 

_AEABI_LC_CTYPE=C 

__STRICT_ANSI__=1 

_DEBUG=1 

Creating a New MQX RTOS for KSDK Project in KDS 
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At this point you may see some warnings. This is because in this project there are Compiler 

settings for C and C++ and we have not fixed the C++ Compiler settings. In this case we are not using C++, go to 

menu Project > Properties > C/C++ Build > Settings > Cross ARM C++ Compiler > Includes

Project > Properties > C/C++ Build > Settings > Cross ARM 

and add the following definitions. 

Freescale Semiconductor

This is because in this project there are Compiler 

this case we are not using C++, go to 

> Includes and erase all the 

 

Project > Properties > C/C++ Build > Settings > Cross ARM C Compiler > 
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3.15 Go to menu Project > Properties > C/C++ Build > Settings > Cross ARM C Compiler > 

Optimization and select GNU ISO C99 (-std=

3.16 Go to menu Project > Properties > C/C++ Build > Settings > Cross ARM C Compiler > 

Miscellaneous and add the following flag.

 

 

 

 

 

  

-fno-strict-aliasing 
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menu Project > Properties > C/C++ Build > Settings > Cross ARM C Compiler > 

std=gnu99) as ‘Language standard’. 

 

 

Project > Properties > C/C++ Build > Settings > Cross ARM C Compiler > 

and add the following flag. 

Freescale Semiconductor

menu Project > Properties > C/C++ Build > Settings > Cross ARM C Compiler > 

 

Project > Properties > C/C++ Build > Settings > Cross ARM C Compiler > 
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3.17 Go to menu Project > Properties > C/C++ Build > Settings > Cross

check the following options. 

 

 

 

  

Do not use standard start files 

Do not use default libraries 

Remove unused sections 
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Freescale Semiconductor

menu Project > Properties > C/C++ Build > Settings > Cross ARM C++ Linker
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Linker > General and 
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3.18 Go to menu Project > Properties > C/C++ Build > Settings > Cross ARM C++ Linker > 

Miscellaneous check ‘Cross Reference’ opt

 

 

  

  -Xlinker -static  -Xlinker -z -Xlinker muldefs  

defsym=__stack_size__=0x400  -Xlinker 
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menu Project > Properties > C/C++ Build > Settings > Cross ARM C++ Linker > 

option and set the following flags, then press ‘Apply’

 

Xlinker muldefs  -Xlinker --undefined=__isr_vector  -Xlinker 

Xlinker --defsym=__heap_size__=0x200 
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menu Project > Properties > C/C++ Build > Settings > Cross ARM C++ Linker > 

‘Apply’ and ‘Ok’ buttons. 

 

Xlinker --
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3.19 Erase the code in ‘main.c’ and replace it with the code below. As you can notice there is no 

‘main()’ this is because it is in the MQX library code. 

 

  

#include <stdio.h> 
#include <mqx.h> 
#include <bsp.h> 
 
/* Task IDs */ 

#define HELLO_TASK  5 
#define WORLD_TASK  6 
 
extern void hello_task(uint32_t); 
extern void world_task(uint32_t); 
 
const TASK_TEMPLATE_STRUCT  MQX_template_list[] = 
{ 
   /* Task Index,   Function,   Stack,  Priority, Name,     Attributes,          Param, Time Slice */ 
    {WORLD_TASK, world_task, 700, 9, "world", MQX_AUTO_START_TASK, 0, 0}, 
    {HELLO_TASK, hello_task, 700, 8, "hello", 0,                   0, 0}, 
    {0} 
}; 
 
/*TASK*----------------------------------------------------- 
* 

* Task Name    : world_task 
* Comments     : 
*    This task creates hello_task and then prints " World ". 
* 
*END*-----------------------------------------------------*/ 
void world_task(uint32_t initial_data) 
{ 
   _task_id hello_task_id; 
 
   hello_task_id = _task_create(0, HELLO_TASK, 0); 
   if (hello_task_id == MQX_NULL_TASK_ID)  
   { 
      printf ("\n Could not create hello_task\n"); 
   }  
   else  
   { 
      printf(" World \n"); 

   } 
 
   _task_block(); 
} 
 
/*TASK*----------------------------------------------------- 
* 
* Task Name    : hello_task 
* Comments     : 
*    This task prints " Hello". 
* 
*END*-----------------------------------------------------*/ 
 
void hello_task(uint32_t initial_data) 
{ 
   printf("\n Hello\n"); 
   _task_block(); 

} 
 

/* EOF */ 
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4 Run the application 

4.1 Build your application, go to 

 

4.2 Go to menu Run > Debug Configurations…
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Build your application, go to menu Project > Build Project. Alternately click the hammer button.

Run > Debug Configurations… 
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Alternately click the hammer button. 

 



 

Creating a New MQX RTOS for KSDK Project in KDS 

25 Freescale Semiconductor

 

4.3 Select the ‘Debug Configuration’ that matches your connection type, in this example P&E Micro 

connection is used, if you don’t know which your connection type is or you want to change your connection 

type see ‘Appendix C’ at the end this document. Once you double click the appropriate ‘Debug Configuration’, 

the connection settings will appear. In ‘Debugger’ tab select the right ‘Interface’, ‘Port’ and ‘Device Name’, 

then click ‘Apply’ and ‘Debug’.  
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4.4 Open a terminal, select the appropriate port and set baudrate to 115200. 

 

 

4.5 Run the application, you will see “Hello World” in terminal. 
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APPENDIX C: Connection Types 

 

- KDS works with devices which support Open

- You can find Open SDA User’s Guide here: 

http://www.freescale.com/files/32bit/doc/user_guide/OPE

- You can learn more about Open 

https://community.freescale.com/docs/DOC

 

Identify your Connection Type 

 

To find out which your connection type is you

Device Manager, here you can see the connection used by your device. You can see how to open Windows 

device manager in the link below: 

http://windows.microsoft.com/en-us/windows/open

 

MBED Connection 

Please note that this connection is not supported in KDS yet.
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with devices which support OpenSDAv2 connection.  

You can find Open SDA User’s Guide here: 

http://www.freescale.com/files/32bit/doc/user_guide/OPENSDAUG.pdf  

 SDA in the following link: 

https://community.freescale.com/docs/DOC-100720 

o find out which your connection type is you must connect your device to your computer and go to Windows 

Device Manager, here you can see the connection used by your device. You can see how to open Windows 

us/windows/open-device-manager#1TC=windows-7 

this connection is not supported in KDS yet. 
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must connect your device to your computer and go to Windows 

Device Manager, here you can see the connection used by your device. You can see how to open Windows 
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Segger J-link connection 
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P&E Micro Connection 
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Switching or updating your connection firmware 

 

You can download different versions of OpenSDA form our partners’ web sites. 

 

MBED 

1) Go to http://mbed.org/platforms/ 

2) Select your platform 

3) Click on the ‘Step by step firmware update instructions’ link 

 

 

4) Save the latest firmware and follow the instructions to do the update 
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P&E Micro 

 

1) Go to http://www.pemicro.com/opensda/ 

2) Download ‘Open SDA Firmware’ and optionally ‘Windows USB Drivers’ 

 

 

 

3) Extract the content on the .zip file and follow steps in ‘Updating the OpenSDA Firmware.pdf’ 

 

  



 

 

 

Creating a New MQX RTOS for KSDK Project in KDS 

32 Freescale Semiconductor

 

Segger 

 

1) Go to http://www.segger.com/opensda.html 

2) Download the required firmware 

 

 

 

3) Unzip the content of the .zip file and use the binary file to update the firware. Steps to update the 

firware are shown in Open SDA User’s Guide mentioned at the beginning of this appendix. 
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Other useful links 

 

 

CMSIS DAP 

https://mbed.org/handbook/CMSIS-DAP 

 

Binary Files for the mbed Bootloader with Eclipse and GNU ARM Eclipse Plugins 

http://mcuoneclipse.com/2014/04/20/binary-files-for-the-mbed-bootloader-with-eclipse-and-gnu-arm-

eclipse-plugins/ 

 

Segger J-Link Firmware for OpenSDAv2 

http://mcuoneclipse.com/2014/04/27/segger-j-link-firmware-for-opensdav2/ 

 

FRDM-K22F: Debugging with Segger J-Link OpenSDAv2.1 Firmware 

https://community.freescale.com/docs/DOC-101790 

 

FRDM-K22F: Debugging with P&E OpenSDAv2.1 Firmware 

https://community.freescale.com/docs/DOC-101792 

 

OpenSDA Update Instructions for Freescale Freedom Development Boards for Windows 8.1 and Linux 

http://www.element14.com/community/docs/DOC-65460/l/opensda-update-instructions-for-freescale-

freedom-development-boards-for-windows-81-and-linux 

 

P&E Eclipse Update Site for GNU ARM Eclipse Plugins 

http://mcuoneclipse.com/2014/09/11/pe-eclipse-update-site-for-gnu-arm-eclipse-plugins/ 

 

 

 


