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1 Lab Overview

This lab will use a FRDM-K64F board to demonstrate FreeRTOS debugging techniques with
MCUXpresso IDE.

2 Prerequisites

The following items are needed to complete this hands-on lab. This has already been installed on your
computer:
e Hardware
o One FRDM-K64F
e Software
o MCUXpresso SDK for FRDM-K64F
o MCUXpresso IDE: http://nxp.com/mcuxpresso/ide
o Segger SystemView: https://www.segger.com/products/development-
tools/systemview/

3 Using MCUXpresso IDE and Task Aware Debugging

3.1 Basic Debugging
1.0pen MCUXpresso IDE

P#IDE
e
hE

2. Set the workspace directory to C:\MCUXpressolDE_Lab (or your choice of other

new directory location) and click on OK.
1B ediipse Launcher ==

Select a directory as workspace

MCUXpresso IDE uses the workspace directary ta store its preferences and development artifacts.

Workspace: ST TSEEN - [ Erowse

Lise this as the default and do not ask again
+ Recent Workspaces

0K Cancel
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3. Open the Installed SDKs view within the MCUXpresso IDE

. MCUXpressolDE_Lab - Develop - Welcome page - MCUXpresso IDE

File Edit Navigate Search Project Run FreeRTOS Window Help
=R |[® Qi 0O~-Qv|eiv] |

= | [E] |-

B|pnEtdRiS LSS
[ Project .. 22

v QuickAccess || B |[R)
= 8

- B

A\
MCUXpresso IDE (Free Edition) is fully activated

/elcome to MCUXpresso IDE (Free Edition). The software is now fully activated, and can be used for production
MCUXpresso (Free Edition) can be used to generate and download applications with no size limit
Product Documentation

= B @ Welcome 2
E. $

filey/#/C:/NXP/MCUXpressoIDE_10.0.0_318_rc2_1/ide/pages/registeredFreeEdition.htm

The MCUXpresso IDE User Guide provides insiructions for using MCUXpresso. This is also avaliable frem the Help menu
« Help->MCUXpresso User Guide

Further product documentation is provided within the MCUXpresso IDE via the Help menu;
« Help->Help Contents

O Quic.. %

=B
g McUXpressQ IDE (Free Edition) @ nstalled S.. &2 opertie: Console [ Problems Memory € Instructio &l SWO Trace .. ® Power Mea B
sasale 2
~ Start here
= [@Installed SDKs
B new project.
B To install an SDK, simply drag and drop an SDK (zip file/folder) into the 'Installed SDKs' view.
Import SDK example(s)
| Name Version  Location
¥ Import project(s) from file system.

]

&

4. If the FRDM-K64F SDK is not in that view already, open the MCUXpresso SDK

folder on your desktop, and drag and drop the FRDM-K64F SDK .zip file into the
Installed SDKs view.

5.You will get a pop-up dialog that looks similar to below. Click on OK to continue
the import:
e

CA\Dats\FRDM-KB4F sip

B it aske For confiemation o SOK Drsg end Drop instel

The installed SDK will appear in the Installed SDKs view as shown below:

() Installed SDKs 52 [] Properties ) Console [*] Problems [] Memory [} Debugger Console 4 Instruction Trace &0 F

[ Installed SDKs

To install an 50K, simply drag and drop an SDK (zip file/folder) into the Installed SDKs' view.

MName SDK Version Manifest Version  Location

43 SDK_2.x_FRDM-K54F 240 330

=} \FRDM-K64F zip
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7. Find the Quickstart Panel in the lower left hand corner

8. Then click on Import SDK examples(s)...

() Quickstart Pa... (9= Global Variabl. arizbles O Breakpoints

MCUXpresso IDE - Quickstart Panel
e No project selected

= Create or import a project

~ Build your project
(2
s
+ Debug your project R-EH-HF-

~ Miscellaneous

9. Click on the frdmké64f board to select that you want to import an example that can

run on that board, and then click on Next. Note there may be more boards listed on
your training laptop.

® SOCimpor Wamd )
FROM-KB4F I e
L

Avatable bosrds

. Board and/or Device selection page

Selected Device: MKG4FN1MOxxx12 using bosed: FRDM. K64
Target Core:
Description

¥64_120: Kietis® K54-120 MHz, 256KB SRAM Mecrocontrolers (MCUs) based on N ’
ARNA® Cortex®-MM Core

Optimizing FreeRTOS Lab Hand Out Page 5 of 14



A 4
4\

10.Select the “rtos_examples” category and then put a check next to
“freertos_generic” and click on Finish.

B8 sDK Import Wizard

i, The source from the SDK will be copied into the workspace. &
If you want to use linked files, please unzip the 'SDK_2.x_FRDM-KB4F' SDK.
- Import projects

Project name prefix: | frdmk64f_ 4| Project name suffix

Use default location

CANXP\MCUX_workspaces\workspace I\frdm/k64f_ Browse...

Project Type Project Options

@® CProject ( C++ Project ' C Static Library Co++ Static Library SDK Debug Console @ Semihost (O UART
Copy sources
[ Import other files
Examples 2| £ & sﬁ‘ H B
[typeto fiter |

Name Version Bl

[ £ ntag_i2c_plus_examples
v [ £ rtos_eamples
& visualization
[ = freertos_dspi
[ = freertos event
freertos_helle
freertos i2c

freertos_mutex
freertos_queue
freertos_sem
freertos_sem_static
freertos_swtimer
freertos_tickless
freertos_uart
se_hostlib_eamples
usb_examples
wifi_qea_examples
wolfssl_examples

w00 000000

oooo

@

11.Click on the frdmk64f freertos_generic name in the Project Explorer panel.
Verify it’s selected in the Quickstart panel and then click on “Build” in the
Quickstart Panel window to build the project.

) Quickstart Panel =g

~

MCUXpresso IDE - Quickstart Panel

Cioe " Project: framiaaf freertos. generic (Debug]

+ Create or import a project

B8 new project.

-
Import SDK example(s)...

& Import project(s) from file system

~ Build your project

=o
- Debug your project E-EH-H-

%Dsbug
12.You can see the status of the build in the Console tab.

& Console 57 s

-5
B R & 2B

CDT Build Console [frdmk64f_demo_apps_hello_world]

arm—nun:—ea}n—g:: —;td:ganB -DCR_INTEGER_PRINTF -DDEBUG -DPRINTF_FLOAT_ENABLE=8 -DSCANF_FLOAT_ENABLE=@ -DPRINTF_ADVANCED_ENABLE=8 -DSCANF_ADVANCED E -

Invoking: MCU C Compiler

arm-none-eabi-gcc -std=gnu99 -DCR_INTEGER_PRINTF -DDEBUG -DPRINTF_FLOAT_ENABLE= -DSCANF_FLOAT_ENABLE=@ -DPRINTF_ADVANCED_ENABLE=@ -DSCANF_ADVANCED_E

Building file: ../drivers/fsl_smc.c

Invoking: MCU C Compiler

arm-none-eabi-gcc -std=gnu99 -DCR_INTEGER_PRINTF -DDEBUG -DPRINTF_FLOAT_ENABLE= -DSCANF_FLOAT ENABLE=@ -DPRINTF_ADVANCED ENABLE=@ -DSCANF_ADVANCED_E

Finished building: ../drivers/fsl_common.c

Finished building: ../drivers/fsl gpic.c

Finished building: ../drivers/fsl_smc.c

I

TP m

13.Make sure the FRDM-K64F board is connected from your laptop to the micro USB
connection labeled “SDA USB”
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14.Click on Debug in the Quickstart Panel.

) Quickstart Pa...

- MCUXpresso IDE - Quickstart Panel
l_oe ) Project: frdmk64f_hello_world [Debug]

 Create or import a project

. New project...
I_.
Import SDK example(s)...

% Import project(s) from file system...

m

~ Build your project
@ Build

.jf Clean
~ Debug your project

4 Debug

~ Miscellaneous

B-E-H-

15.MCUXpresso IDE will probe for connected boards and should find the MBED
CMSIS-DAP debug probe that is part of the integrated OpenSDA circuit on the
FRDM-K64F. In the dialog box that comes up, change the IDE Debug Mode to
“All-Stop” which allows for a thread aware debug view.

Connect to target: MK64FN1MOxxx12

1 probe found. Select the probe to use:

Available attached probes

N Serial number.. Type  Man.. IDEDebug Mo..

ame.
[ DAPLink CMSIS-DAP 0240000028884« LinkSer ARM  All-Stop v

e

SEGGER J-Link probes

Probe search options

Search again
|

Remember my selection (for this Launch configuration)

@

16. The firmware will be downloaded to the board and the debugger started.

17.Start the application by clicking the "Resume" button and see the messages in the

console. Use the other debug buttons to Pause, Step In, Step Out, and Step Over
code.

FreeRlUS  Window Help
‘ b [ S e

Resume (F8)
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18.Press the “Pause” button and explore all the FreeRTOS tasks. Click on a function
(top of the thread) and debug it by stepping out or stepping over.

45 Debug 5 [ N N ¥ =8
[ frdmkssf freertos_generic LinkServer Debug [C/C++ (NXP Semiconductors) MCU Application] ~
~ [ frdmkEaf _fre SAFN 1M O00c12 (corbex-md)]

spended : Container)
ive() at queue.c:1'345 0x20b0
1

19. When finished, press the Terminate button to stop the debug session. _
20.If needed, you can get back to the Develop view by clicking on the icon in the

upper right corner. JES

3.2 FreeRTOS Task Aware Debugging

1. Using the same freertos_generic project as the last section, start a debug session,
run the code, and then hit pause in the debugger.

2. Open the FreeRTOS Task List by going to FreeRTOS in the menu bar and select
Task List. Review the information that shows all the tasks currently running.

FreeRTOS  Window Help

Tirner List

Heap Usage

NP Community
About FreeRTOS TAD

=
=
=
&
o)

3. You can save the task data as a .csv file if desired by clicking on the floppy disk
icon.

4. View the FreeRTOS Queue List by going to FreeRTOS->Queue List

5. View the FreeRTOS Timer List to see all the RTOS timers being used by going to
FreeRTOS->Timer List

6. View the FreeRTOS Heap Usage to see the status of Heap and Memory allocation
by going to FreeRTOS->Heap Usage

7. When finished, press the terminate icon and wait for instructor. Do not proceed to
next section yet.
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4 FreeRTOS Advanced

4.1 FreeRTOS Optimization

1. Import the FRDM-K64F SDK FreeRTOS project found on the desktop by
dragging the folder into the empty space in the Project Explorer view. This project
is designed to show off FreeRTOS features.

(S frdmk84f_generic_freettos_generi

>

2. In the dialog box that comes up, select “Copy”

| @)X A you sureyouwant to import the following projects?
&Y' C\tmphtraining) projects\FROM-K&4F_SDK_FreeRTOS'?
Link

| Copy i Cancel

3. With the project now imported, build the project and make note of the initial code
and data size needed.

Memo: region Used Size Region Size %age Used

1 MB 5.42%

192 KB 23.80%
1] 3 64 KB 0.00%
FLEX RAM: 0 GB 4 KB 0.00%

4. Change the libraries and semihosting/printf to disable and save code space
a. Use the RedLib library by opening the Project Settings category in the
project, and right clicking on the Libraries folder and selecting RedLib
(nohost).

[y Project Explorer 37 | 2, Peripherals+ 1] Registers {£) Symbol Viewer = 0

w 55 » FRDM-K64F_SDK_FreeRTOS [McuOnEclipse master]

b. Rebuild and check code size impact
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5. For the rest of this lab, each specific item to change is associated with a TODO.
You can view a list of the TODOs by opening the Tasks view: Windows->Show
View->Other and then General->Tasks. You can double click on the items in the

list to "umi to the specific source location.
V4 Show View | X

tas
~ (& FreeRTOS = 5 & Tasks 12
# Task List (FreeRTOS;
v L"C&b 12 iterns
& Tasks S
! Description Resource Path Location Type
TODQ 01 disable assert to reduce code size (1==>0)  FreeRTOSConfig.h /FRDM-K64F_SDK_... line 98 C/Ce+ Task
TODQ 02 Set a queue size of 3 (from the original 0 (dis... FreeRTOSConfig.h /FRDM-KB4F_SDK_... line 56 C/C++ Task
TODQ 03 Enable stack low address listed in TCB for be.. FreeRTOSConfig.h /FRDM-KB4F_SDK_... line 160 C/C++ Task
TODQ 04 reduce IDLE stack size from 200 => 150 FreeRTOSConfig.h /FRDM-KB4F_SDK_... line 47 C/C++ Task
TODQ 05 reduce TmrSve stack size: ((configMINIMAL... FreeRTOSConfig.h /FRDM-KB4F_SDK_... line 95 C/C++ Task
TODOQ 06 reduce Timer queue length (10=> 3) FreeRTOSConfig.h /FRDM-KB4F_SDK_... line 94 C/C++ Task
TODQ 07 ch h tod==>1(allocat.. FreeRTOSConfig.h /FRDM-KB4F_SDK_... line 65 C/C++ Task
ez TODO DgZn::\g:.m‘?:g;;?:(DD::>1) e F:::RTOSEZ:f:zh JFRDM-KB4F_SDK_. \:::sa c_rcHT::k
6. These changes will all be done in the \source\FreeRTOSConfig.h file
7. Disable ASSERTS for release version by changing the #if 1 on line 98
to #if 0. Recompile the project and make note of the code size change.
8. Enable the Queue Registry by setting

configQUEUE_REGISTRY_SIZE on line 56 to 1 and verify by debugging the
project and using TAD to view the FreeRTOS Queues.

The next few steps will be used to optimize the stack size

0. Enable the recording of the stack address in order to debug stack size
usage. On line 160 change configRECORD _STACK HIGH_ADDRESS to |

10. Decrease the stack size for the IDLE task to save RAM. On line 47
change configMINIMAL_STACK_ SIZE to 150.

1. Reduce the stack for the TmrSvc task which controls the FreeRTOS
timers to save RAM. On line 95 change configTIMER TASK STACK DEPTH
to 150

12. Reduce the Timer queue length to save RAM. On line 94 change

conficTIMER QUEUE_LENGTH to 3.
13.Compile and Debug the project. Run for a while and then hit pause in the

debugger.
14.Look at the FreeRTOS->Task List view and note the stack usage. Remember that

the values put into the code are in 32-bit units.

) Installed SD... [T] Properties [ Console [/ Problems [J Memory E Debugger C... & Instruction ... BD Power Meas... £ SWO Trace... 3% Timer List (F... J=| Tasks r# Queue List (F... | Task List (Fr.. 3%
g

TCB“A Task Name Task Handle Task State Priority Stack Usage Event Object Runtime

1 Timers 0x20000cd0 [l Blocked 0 276B /49 B &y

2 Master 0x20000f48 (0 Blocked 01 324B/49 B Fiy

3 first_task 0:200011c0 [0 Blocked 0@ 336B /49 B &

4 IDLE 020001438 B+ Running 0(0) 88B /5928 iy

5 Tenr Sve 0x200017f8 [l Blocked 0@ 365B/5928 TrnrQ () &

6 second_task 0x20001a70 [l Blocked 003 136B /49 B &y

7 Slave (20001 d40 Suspended o 220B /496 B iy
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15. Now change the heap allocation scheme to “Allocate Only”. On line 64
change configFRTOS MEMORY_SCHEME to 1.
16. Enable Runtime stats by modifying line 83 to change

configGENERATE _RUN _TIME_STATS to 1.
17.Compile and run the project. View the Task List again to see which tasks are
running the most often.

() Installed SD... [] Properties [ Console [ Problems (] Memory [} DebuggerC.. €& Instruction... ®D PowerMeas.. []SWOTrace... 1 TimerList(F.. ) Tasks r#% Queue List(F.. rov Tasklist(Fr.. | = O
ulge

aaaaaaaa

18.There’s a performance issue in this code. Can you spot it? While the code is
running, hold down SW3, and then look at the Runtime statistics again.

19.This can be fixed. Add the following line in FreeRTOS Timers.c on line 84 to add
a delay inside the while() loop that waits for SW3 to be unpressed. Run again and
checks the Runtime statistics.
vTaskDelay(pdMS TO TICKS(50));

20.When finished, hit the terminate icon to stop the debug session.

4.2 FreeRTOS with SystemView

1. SystemView requires the Segger debug interface. We can change the debug
interface on the OpenSDA circuit on the FRDM-K64F with the following steps:
a. Unplug the board
b. Press and hold the reset button on the board while plugging the board back
into the computer
c. The board will enumerate as MAINTENANCE on your computer
d. Copy OpenSDA\SEGGER 02 OpenSDA_FRDM-K64F.bin to drive
e. Unplug the USB cable and replug back in.

2. Inside of MCUXPresso IDE, hold down the shift key and then click on Debug
from the Quickstart menu. This will rescan for debug probes to find the new JLink
firmware.

3. It should find the JLink software. Click on OK.
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4. You may get the following dialog box. Click on the box to not show the message
again and then click on Accept.

Thecormecid omidr s DA nrring ik compable frure
make.

DperSDA wrring i
D e L L R

[TERME OF USE

1 The s i 0 s s il Fseical gt dics, Using i i thsdics i
d legal

2\ ory.

£ whe s fordervelops M may nol be used for

poducton ppeses

)
15 T fimusar may be sed whh the DpenSDi platiom ook

e da mdeied v
i tocomma g i o SEGGER i 10 ute:
SEGGER, please

herdmere,

u ok PAO It ogger comfink pra i)
e, ra i

IFan pressiceal production fash programin e recommand

¥ Do ot shaw i message agan for ocay Decine Accept

W

Terminate the debug session.

Go to Run->Debug Configurations from the menu bar at the top

7. Make sure to select the “FRDM-K64F SDK FreeRTOS JLink Debug”
configuration and then on the Debugger tab, scroll down to check “Select RTOS
plugin” so it is enabled. Hit Close to save.

5

B Debug Configurations X
Create, manage, and run configurations 6—
X[E B~ Name: | FROM-KE2F_SOK_FreeRT0S ink Debug
| n....ecum < Tool - Startup) - Source, (] Common
Y ink @use [1234% ow
MKG4EN Mo
o
O adapt ved
e
Run

tartup symbol/address
EAvesty EASinglerun. [l Attach to a rumming target

ot Blowse
] Setect RIOS phugin GDBServes/RTOSPhugin_FreeRIOS
Other server options
Flter matched 18 of 18 tems
Z Debug Close

8. Click on “Debug” from the Quickstart Window and click on the “Resume” button
to begin running the code in the debug session.

9. Launch SystemView
10.Press Start Recording

Ay SEGGER SystemView V2.52a - SEGGER start project [embOS] on MKEGF]

File View Go Target Tool Window  Help

@ 5 E3 O Firecordng ~| @ |

Context Event

Idle ¢ Start
Idle
Idle
Idle
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11.Specify the target device: MK64FN1MOXXX12 and hit OK.

A SEGGER SystemView V2.52a | Co.. 7 X

Connection to J-Link

@ Uss [ serial No
O TerjP

Target Device

|[MrernmMoooz | V]
I |

Target Interface & Speed
SWD - |3000 2 khz

RTT Control Block Detection

®) Auto Detection () Address (0) Search Range
Automatically search for RTT Control Block in known RAM.

12.1t will record data. After a few seconds, press Stop Recording.

13.Explore the SystemView interface. Use the mouse wheel to zoom in and out of the
timeline, and the mouse to move the time.

14.You can see the list of events in the Events window. Click on an event to see it in
the Timeline view.

15.View the messages sent to the terminal in the Terminal window. These are

generated by a Segger API used in the code.

16. View the run count, statck size, task frequency, and more in the Contexts
window.

17. Reduce the tick frequency so don’t wakeup so often. On line 45 change
configTICK_RATE_HZ to 200.

18.Compile and record the system again like done previously. You should now see
reduced number of ticks.

19. Use tickless mode. On line 43 change configUSE_TICKLESS IDLE
to 1.

20.Compile and run the code again and see a greatly reduced number of interrupts.

21.When finished experimenting with SystemViewer, put OpenSDA back into
bootloader mode (holding down reset) and load
OpenSDA\DAPLINK k20dx_frdmk64f if crc_legacy 0x5000.bin on it.
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4.3 FreeRTOS Compiler Optimization

This section is last because these compiler optimizations can impact debugging.

22.Increase the optimization level used by the compiler by opening Project Settings-
>QOptions and right click to select Edit Options.

5 Project Explorer 33 | 2, Peripherals+ {if Registers ) Symbol Viewer = B8

v 1§ = FRDM-K&4F_SDK_FreeRTQS [McuOnEclipse master]
~ @ Project Settings
=) Aszociated SDK
= Libraries (and semihosting)

€ MCU
Wil Memory
~ [ Optior:
o Def|d Eeres FPU_MKE4FNTMOVDT 12_cmd, CPU_MKE
g;v? Binaries w

23.Inside the Optimization category, change the Optimization level to -Os and then
recompile. Note the code size changes.

& Tool Settings & Build steps Build Artifact Binary Parsers @ Error Parsers

~ 1 MCU C Compiler Optimization Level

(= Dialect
(i Preprocessor
3 Includes
(% Optimization

Other optimization flags

[IEnable Link-time optin
Fat lto abjects (fat-

(% Debugging
(B Warnings
(8 Miscellaneous
(2 Architecture

24.Enable Link-Time optimization by enabling it for both the compiler and linker.
Open up the Project Settings again, and
a. Under MCU C Compiler->Optimization select “Enable Link-Time
optimization (-flto)”.

B Tool Settings & Build steps Build Artifact Binary Parsers @3 Error Parsers

~ B MCU C Compiler
(3 Dialect
o Other optimization flags | -fno-commaon |
(&2 Preprocessor

Optimization Level Optimize for size (-Os) ~

@ Includes Enable Link-time optimization (-flto}

(% Optimization Fat lto objects (-ffat-lto-objects)
# Debugging

b. Under MCU Linker->General, select “Enable Link-time Optimization (-
flto)” and set the optimization level to -Os.

B Tool Settings 5 Build steps

~ 8 MCUC Compiler

25.Compile and compare code sizes.
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