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About this document 

KBOOT flash resident bootloader is a programming firmware to initially load or upgrade the application 

in a target Kinetis device over a supported interface such as UART, USB HID, SPI, I2C or CAN. 

This document explains the required modifications to be made to an existing Kinetis Design Studio 

project so it can be loaded using KBOOT flash resident bootloader. 3 types of projects are covered: 

- Baremetal project 

- KSDK project 

- KSDK + Processor Expert project 

The example steps  are for the MK22FN512xxx12 target like the one in FRDM-K22F board, but the same 

principles are applicable to any target supported by KBOOT flash resident bootloader. 

 

Software versions 

Instructions in this document are valid for the latest versions of the software tools by the time of 

writing, listed below: 

 Kinetis Bootloader v1.2.0 

 KSDK v1.2.0 

 KDS v3.0.0 
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1. GLOSSARY 
 
KBOOT Kinetis Bootloader: Configurable flash programming software for programming Kinetis MCUs.  

KSDK Kinetis Software Development Kit: Set of peripheral drivers, stacks and middleware layers for 

Kinetis microcontrollers. 

KDS Kinetis Design Studio: Integrated Development Environment (IDE) software for Kinetis MCUs. 

BCA Bootloader Configuration Area: Data stored in Flash memory space to configure various 

features of the Kinetis bootloader. 

FCF Flash Configuration Field: 16-byte space at fixed address range 0x400 – 0x40F in Kinetis flash 

memory that stores protection and security settings, as well as other boot and power options 

depending on the device. Specific information for each device is in the Reference Manual. 
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2. CONCEPTS AND OVERVIEW 
 

This section introduces the concepts and theory to understand the modifications in a  project to work 

with KBOOT flash resident bootloader. 

2.1 Relocating vectors and application 
 

In a default Kinetis project the interrupt vector table is placed at the start of Flash memory (address 

0x0000_0000) followed by the application code. For a target MCU to have a Flash resident bootloader, 

some Flash memory space must be reserved for the bootloader, usually at the start of Flash. This 

involves that the user application vector table and the application itself need to be moved to a higher 

address, depending on the space used by the bootloader. With RAM memory there should be no 

problem, as long as the application initializes the stack pointer and loads the initial variables or code to 

RAM memory as required, which are standard steps in any Kinetis project. 

In particular for the KBOOT flash resident bootloader, the Flash memory layout is shown in below 

picture (just illustrative, not drawn to scale): 
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2.2 Bootloader Configuration Area (BCA) 
 

The Bootloader Configuration Area (BCA) is located at an offset of 0x3C0 from the beginning of the user 

application image. This information is read by the Kinetis bootloader early during the bootloader 

initialization in order to set up clocks and gather other information relevant to detecting active 

peripherals. If the first four bytes of the BCA are not ‘kcfg’, the bootloader does not use any information 

from the BCA on flash. 
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3. ADAPTING KDS PROJECTS 
 

There are 3 basic steps to prepare a KDS project for KBOOT flash resident bootloader: 

1- Move vector table and code by adding offset in linker file. 

2- Remove the flash configuration data and the linker placement for FCF. 

3- (Optional) Add BCA section to linker file and define BCA data in the code. 

NOTE 

 
 

- The linker file (.ld extension) is usually located in <project>/Project_Settings/Linker_Files. 

In case you cannot find the linker file, from KDS you can go to Project -> Properties -> C/C++ 

Build -> Settings -> Cross ARM C++ Linker and see the path to the linker file used by the project. 

 

- The offset is defined as  BL_APP_VECTOR_TABLE_ADDRESS in the file bootloader_config.h 

for each target, in the path: 

 

<install_dir>/targets/<mcu>/src/bootloader_config.h 

 

- The current host applications (Kinetis Updater and blhost) in KBOOT v1.2.0 support the binary 

file format. Refer to Appendix A – Binary file generation in KDS. 

 

3.1 Baremetal project (with or without KSDK) 
 

In a default baremetal project (without Processor Expert) the memory segments of MK22FN512xxx12 

are defined in the linker file as next:  

The examples in this chapter are for a MK22FN512xxx12, 

but same steps are applied to any KBOOT supported 

target, considering the particular memory sizes. 
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- Remove the m_flash_config MEMORY segment. Also remove the .flash_config section from 

SECTIONS in the linker file: 

 

 
 

- Delete the flash configuration data from the startup file (startup_<device>.S): 

 

 
 

NOTE 

 
 

- Add the application offset (in this case 0xA000) to m_interrupts and m_text. In the default 

memory segments, the ORIGIN of m_text has an offset of 0x10 (16 bytes) due to the Flash 

Configuration Field. Since FCF is no longer present, we can move the origin to avoid wasting 

memory and add the 0x10 to LENGTH. 

- Subtract the application offset from the LENGTH parameter of m_text segment. 

  

If any custom flash configuration is required, it should 

be programmed together with the bootloader firmware, 

since it will not be part of the application project. 

MEMORY 
{ 
  m_interrupts          (RX)  : ORIGIN = 0x00000000, LENGTH = 0x00000400 
  m_flash_config        (RX)  : ORIGIN = 0x00000400, LENGTH = 0x00000010 
  m_text                (RX)  : ORIGIN = 0x00000410, LENGTH = 0x0007FBF0 
  m_data                (RW)  : ORIGIN = 0x1FFF0000, LENGTH = 0x00010000 
  m_data_2              (RW)  : ORIGIN = 0x20000000, LENGTH = 0x00010000 
} 
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The new memory segments should be as next: 

 

 
 

[m_interrupts]  ORIGIN = default + offset = 0x00000000 + 0xA000 =  0x0000A000 

   LENGTH = Unchanged 

[m_flash_config] Removed 

[m_text] ORIGIN = default + offset - 0x10 = 0x00000410 + 0xA000 - 0x10 = 0x0000A400 

  LENGTH = default + 0x10 - offset = 0x7FBF0 + 0x10 - 0xA000 = 0x000075C00 

 

 

(OPTIONAL) Adding BCA 

 

- If BCA is required, then add  m_bca memory segment, with ORIGIN = offset + 0x3C0 and LENGTH 

= 0x40. By default m_interrupts has a LENGTH of 0x400, but not all of that space is used by the 

vectors, so it is possible to reduce it to 0x3C0 to avoid an overlap. 

The new segments will be as next: 

 

 
 

[m_bca] ORIGIN = offset + 0x3C0 = 0xA000 + 0x3C0 = 0x0000A3C0 

  LENGTH = 0x40 

 

- In the SECTIONS part of the linker file, add an output section called .bca with the next syntax: 

 

MEMORY 
{ 
  m_interrupts          (RX)  : ORIGIN = 0x0000A000, LENGTH = 0x000003C0 
  m_bca                 (RX)  : ORIGIN = 0x0000A3C0, LENGTH = 0x00000040 
  m_text                (RX)  : ORIGIN = 0x0000A400, LENGTH = 0x00075C00 
  m_data                (RW)  : ORIGIN = 0x1FFF0000, LENGTH = 0x00010000 
  m_data_2              (RW)  : ORIGIN = 0x20000000, LENGTH = 0x00010000 
} 

MEMORY 
{ 
  m_interrupts          (RX)  : ORIGIN = 0x0000A000, LENGTH = 0x00000400 
  m_text                (RX)  : ORIGIN = 0x0000A400, LENGTH = 0x00075C00 
  m_data                (RW)  : ORIGIN = 0x1FFF0000, LENGTH = 0x00010000 
  m_data_2              (RW)  : ORIGIN = 0x20000000, LENGTH = 0x00010000 
} 
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- The startup file has 256 vectors defined, from which some are just dummy vectors to fill the 

default 0x400 length from the m_interrupts segment. Since length has changed to 0x3C0, we 

need to remove the last 16 dummy vectors to avoid a linker error. 

 

 
 

- Finally add the required Bootloader Configuration data to the startup file (startup_<device>.S) 

just after the vectors definition, starting by the “kcfg” tag. 

The values are dependent on the user options, refer to the KBOOT Reference Manual for 

information about each field. Below is just an example configuration: 

 

  .bca : 
  { 
    . = ALIGN(4); 
    KEEP(*(.bca))    /* Bootloader Configuration Area (BCA) */ 
    . = ALIGN(4); 
  } > m_bca 
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3.2 KSDK + Processor Expert project 
 

In a Processor Expert project the linker file generation is in charge of PE unless such feature is disabled. 

- Open the CPU component properties and go to Build Options -> Generate Linker file. There you 

will find the default memory segments. Next is an example for the MK22FN512xxx12: 

 

/* Bootloader Configuration Area (BCA) */ 
    .section .bca, "a" 
    .ascii   "kcfg"  // [00:03] tag 
    .long 0xFFFFFFFF // [07:04] crcStartAddress 
    .long 0xFFFFFFFF // [0B:08] crcByteCount 
    .long 0xFFFFFFFF // [0F:0C] crcExpectedValue 
    .byte 0xFF  // [10] enabledPeripherals 
    .byte 0xFF  // [11] i2cSlaveAddress 
    .short 5000  // [13:12] peripheralDetectionTimeout (milliseconds) 
    .short 0xFFFF  // [15:14] usbVid 
    .short 0xFFFF  // [17:16] usbPid 
    .long 0xFFFFFFFF // [1B:18] usbStringsPointer 
    .byte 0xFF  // [1C] clockFlags 
    .byte 0xFF  // [1D] clockDivider 
    .byte 0xFF  // [1E] bootFlags 
    .byte 0xFF  // [1F] reserved 
 
    .rept (0x400-0x3E0)/4 // To fill binary range 0x3E0 - 0x400 with 0xFF 
    .long 0xFFFFFFFF 
    .endr 
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- Edit the memory areas following the same rules explained in the previous section for baremetal 

projects. Such rules are listed below: 

 

[m_interrupts]  ADDRESS = default + offset = 0x00000000 + 0xA000 =  0x0000A000 

   SIZE = Unchanged 

 

 [m_text] ADDRESS = default + offset - 0x10 = 0x00000410 + 0xA000 - 0x10 = 0x0000A400 

  SIZE = default + 0x10 - offset = 0x7FBF0 + 0x10 - 0xA000 = 0x000075C00 
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The edited areas and ranges for the case of MK22FN512xxx12 would be as next: 

 

 

 

- Open the startup file (startup_<device>.S ) and remove the flash configuration data: 

 

 
 

 

 

(OPTIONAL) Adding BCA 

 

- Open the Build Options from the CPU component and disable the Linker file generation to avoid 

Processor Expert overwriting the next custom changes to the linker file. 
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- Add m_bca memory segment to the linker file (ProcessorExpert.ld), using ORIGIN = offset + 

0x3C0 and LENGTH = 0x40. Also change the LENGTH of m_interrupts from 0x400 to 0x3C0. 

Updated segments will look as next: 

 

 
 

[m_bca] ORIGIN = offset + 0x3C0 = 0xA000 + 0x3C0 = 0x0000A3C0 

  LENGTH = 0x40 

 

- Inside of the SECTIONS part in the linker file, add a new output section called .bca defined as 

shown below: 

 

 
 

- Remove the last 16 dummy vectors defined in the startup file to avoid linker errors due to the 

change of the m_interrupt segment’s length in a previous step: 

 

  .bca : 
  { 
    . = ALIGN(4); 
    KEEP(*(.bca))    /* Bootloader Configuration Area (BCA) */ 
    . = ALIGN(4); 
  } > m_bca 

MEMORY 
{ 
  m_interrupts          (RX)  : ORIGIN = 0x0000A000, LENGTH = 0x000003C0 
  m_bca                 (RX)  : ORIGIN = 0x0000A3C0, LENGTH = 0x00000040 
  m_text                (RX)  : ORIGIN = 0x0000A400, LENGTH = 0x00075C00 
  m_data                (RW)  : ORIGIN = 0x1FFF0000, LENGTH = 0x00010000 
  m_data_2              (RW)  : ORIGIN = 0x20000000, LENGTH = 0x00010000 
} 
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- Last step is to add the custom bootloader configuration (BCA) to the startup file after the 

definition of the interrupt vectors. Make sure to start with the tag “kcfg” for the configuration to 

be valid. The configuration is user-dependent, check the KBOOT Reference Manual for 

information about the available fields. 

 

An example BCA configuration is shown below: 

 

 

  

/* Bootloader Configuration Area (BCA) */ 
    .section .bca, "a" 
    .ascii   "kcfg"  // [00:03] tag 
    .long 0xFFFFFFFF // [07:04] crcStartAddress 
    .long 0xFFFFFFFF // [0B:08] crcByteCount 
    .long 0xFFFFFFFF // [0F:0C] crcExpectedValue 
    .byte 0xFF  // [10] enabledPeripherals 
    .byte 0xFF  // [11] i2cSlaveAddress 
    .short 5000  // [13:12] peripheralDetectionTimeout (milliseconds) 
    .short 0xFFFF  // [15:14] usbVid 
    .short 0xFFFF  // [17:16] usbPid 
    .long 0xFFFFFFFF // [1B:18] usbStringsPointer 
    .byte 0xFF  // [1C] clockFlags 
    .byte 0xFF  // [1D] clockDivider 
    .byte 0xFF  // [1E] bootFlags 
    .byte 0xFF  // [1F] reserved 
 
    .rept (0x400-0x3E0)/4 // To fill binary range 0x3E0 - 0x400 with 0xFF 
    .long 0xFFFFFFFF 
    .endr 
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Appendix A – Binary file generation in KDS 
 

1) Once the project is open in KDS, go to Project -> Properties -> C/C++ Build -> Settings -> 

Toolchains. Enable the checkbox for “Create flash image” and click on Apply: 

 

 
 

2) Go to Tool Settings -> Cross ARM GNU Create Flash Image -> General. In the “Output file format 

(-O) option select Raw binary. Click on Apply and then OK or close the Properties window. 
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3) Build the project. Once the build process is over, you should find the generated binary file (.bin 

extension) inside of the build folder called “Debug” by default: 
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Appendix B - References 

 

- KSDK webpage:   www.freescale.com/ksdk 

 

- KDS webpage:   www.freescale.com/kds 

 

- KBOOT webpage:  www.freescale.com/kboot 

 

- KBOOT documents:  C:\Freescale\FSL_Kinetis_Bootloader_1_2_0\doc 

 

- How to create a baremetal KSDK project in KDS: 

https://community.freescale.com/docs/DOC-103288 

 

- Interrupt handling with KSDK and Kinetis Design Studio: 

https://community.freescale.com/docs/DOC-104352 

 

- Kinetis Design Studio videos: 

 Installation of KDS and Kinetis SDK: https://community.freescale.com/videos/3281 

 Installation of OpenSDA Firmware: https://community.freescale.com/videos/3282 

 Debugging with KDS: https://community.freescale.com/videos/3283 
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