AnsweredAssumed Answered

Kwikstik rev 5 + CodeWarrior: patch needed, any experience?

Question asked by Michele Marchetti on Oct 28, 2011
Latest reply on Nov 4, 2011 by Michele Marchetti

Dear all,

 

I finally got a Kwikstikc rev 5 so that I can start use the SD card support (which was broken by design in rev 4).

I am using CodeWarrior 10.1.

 

While attempting to access to esdhc I get the following error:

 

    com_handle = fopen("esdhc:", NULL);
    if( !com_handle ) {
        printf("DBG: Opening ESDHC device failed, is ESDHC controller enabled in MQX?");        


Problem is that I have to enable ESDHC in bsp, but the
init_bsp.c
file retreives me the following error:

#error This modul unsupported with Kiwkstik Board.Please disable BSPCFG_ENABLE_ESDHC to 0 in user_config.h

 

Is there anyway around this?

Did anyone used the rev 5 of Kwikstik with codeWarrior?

 

I asked to Freescale for a patch for MQX and Kwikstik rev 5, which should prevent that re-compiling error of bsp to happen, but they said there is none available.

 

Any hint?

thanks,

Mik

 

Outcomes