AnsweredAssumed Answered

PE components are created but do not show up in CW10

Question asked by Antonio Quevedo on Aug 19, 2011
Latest reply on Aug 19, 2011 by Antonio Quevedo

Hello,

 

I am moving to CW10, and I am trying to create a new project from scratch for the TWR-MECH board (target processor MCF52259). I want to use Processor Expert (PE). My CodeWarrior is Version 10.1, Build Id 110726, Special Edition. During the "create new project" wizard, I selected the bare target processor, not any of the option for tower boards.

 

I selected a PE component (PWM Component) at the Components Library pane, then I clicked on it with the right button, and selected "Add to project" option. However, the PWM component did not show up at the Project Panel (and I cannot see any "Embedded Components" folder inside the project either). My first thought was that I did not select the Add option correctly, so I tried that again. No changes. The CPU component  also does not show up right after the new project wizard finished, as it happened in previous versions of CW.

 

So I tried to click on the "Generate Processor Expert Project" button at the Project Panel. I get an error message stating that there is some error. Looking at the Problems tab, I find errors related to PWM1 and PWM2 components. When I double-click on one of these messages, the Component Inspector pane is loaded with the config options of the PWM component, showing the errors: unassigned timings for period and starting pulse width. it means that the components were created, but do not show up in the Project Panel.

 

I right-clicked at the project panel and chose Refresh to see what happened. Nothing.

 

I suppose it has something to do with the CW configuration. I can configure any components that are not fully configured when created (because of the errors), but after configured i cannot access them anymore.

 

How can I fix it? Just a reminder, the installation is brand new, I did not alter any default configs. I also tried the same install in 2 computers (one running WinXP and the other on Windows 7).

 

Thanks in advance

Outcomes