AnsweredAssumed Answered

environment mystery

Question asked by Ron Wilson on Feb 5, 2011
Latest reply on Feb 10, 2011 by Ron Wilson

I am using CW 5.0 for S12X.

 

One of the tools that came with CW is maker.exe, which I use to run my own make files. I am encountering some kind of environmental issue that eludes me and my co-workers. Since the issue involves a 3rd party IDE, I first tried posting to their forum. Noone their was able to help. Maybe someone here might have an useful idea.

 

My make file is included as an attachment to this post. (I had to change the extension from .mak to .txt to get it accepted by the forum system, here.)

 

I used the following to invoke the make file from the directory it resides in:

 

C:\Freescale\CodeWarrior_for_S12X_V5_0\Prog\maker.exe "Pod.mak" all

 

When I run this command from a Wondows Cmd prompt, nothing happens, not even any error messages. Nothing gets compiled, linked or otherwise built.

 

When I run this command from inside the 3rd IDE, it works as expected, compiling all the source files and linking the ABS file, which I can then successfuly program into my target and successfully run.

 

I have carefully compared the 2 environments, including using the set command to list the values of all the environment variebles. I even tried setting all the environment variables set within the IDE's command shell, but even that did not get the make file to run as expected.

 

At this point, I am considering porting my make file to another version of make and using that instead of maker.exe, but I would really prefer to get this working with maker.exe

Outcomes