Kevin Meyer

Crazy errors trying to install Codewarrior 10 on Ubuntu 10.10 (amd64)

Discussion created by Kevin Meyer on Dec 9, 2010
Latest reply on Dec 10, 2010 by Kevin Meyer

Dear all,

Am I going crazy or have I missed something?

I have downloaded the 700MB tar file from the Special Edition web page.

When I extract it, it creates a single directory called "disk1".

Inside that directory, there is an executable script called "setuplinux".

 

When I run that script, it terminates with an error message saying there is insufficient disk space in /tmp to extract the files. But there is more than 30GB free!

 

If I tell it to ignore disk space checks (-is:nospacecheck), it fails with "no JRE installed". But the open JDK is pre-installed.

I have even installed the jre/jdk from Sun (java6). Still no luck.

When I try and specify the java home (-is:javahome <path the any of the jre's>), it still fails.

 

If I enable debugging (-is:log debug.log [I think, I can't remember offhand]), the log file contents messages saying that it can't find the JRE from the environment or the jvmlist..

 

If I manually run the installation wizard: "java -cp mcu_10.jar run" (or whatever the jar is called), the install shield dialog comes up, and after I specify the target directory, the wizard spends about 20 - 30 seconds doing nothing (no network, disk or CPU activity) before complaining about a missing dependency (ldd) and that cwde is not installed.

Thereafter there are a few more error dialogs.

After all this, there are no files installed at the installation directory (/usr/local/Freescale/...).

 

Please, what am I missing? 

 

Has anyone installed onto Ubuntu 10.10 64bit?

 

Regards,

Kevin

Outcomes