AnsweredAssumed Answered

Files Missing From File View Hierarchy

Question asked by Steve Lewis on Nov 8, 2010
Latest reply on Nov 15, 2013 by Harold Kraus

Hi

I am using Code Warrior Development Studio for the S12(X) Version 5.0, build 9061.

The target is an MC9S12A128 device.

 

I recently added some new code/header files to my project, to support a new feature on the product. I created a new Group in the file hierarchy (called "USB Aux Port") to keep file view tidy. I then created new files, added them to the project and put them in this group, and then started coding.

 

Now my problems started.

1. When I start Code Warrior, I get a message that some files were missing from the hierarchy information for the files view of "GV1.mcp" These files have been added to the Files view hierarchy in a group called "Rescued Items"

 

2. I get a "Project Messages" window with a hep of messages along the lines of: "The following file has multiple entries in target "GV1 Firmware" of project "GV1.mcp" This can cause severe inconsistencies and should be fixed immediately! There then follows the names of the files on my USB Aux Port group.

 

I them have the same files listed in both a "Rescued Items" group and the "USB Aux Port" group.

 

3. I have tried the recommended approach to delete the "GV1_Data" folder in the project folder, and then recompile, but that does not sort out my problems.

 

4. The next time I open the project, all the files in the group are no longer recognised as project files. If I try to compile the project when working on one of these files, I get the "Create New Project" Wizard.

 

5. And if I change one of these files, it is not shown in the Files hierarchy, and the project will not automatically recompile if I click the debug button to download it to the target.

 

6. I tried adding these files to the project again, but now when I open them, I get the warnings about the files having multiple entries.

 

7. Worse still, Code Warrior now has a tendency to crash on me, either when I compile, or when I right click on a function name in one of the offending files, with the intention of navigating to its definition or declaration. And if it doesn't crash when I right click, I get multiple implementations of the function in the listing.

 

Do you have any suggestions please? I suspect there something very simple has gone wrong, but I can't work it out.

Many thanks

Steve

Outcomes