Sergei Poselenov

Booting M53017EVB with uImage and u-boot-able ramdisk image

Discussion created by Sergei Poselenov on Nov 5, 2010
Latest reply on Nov 5, 2010 by Sergei Poselenov

Hello,

I'm trying to boot the M53017EVB with uImage and U-Boot-able ramdisk image, but failed.

I'm using the LTIB-20100126 with M53015 BSP, running "./ltib -c", then selecting 2.6.29 kernel configuration with NFS support, with the "Configure kernel" option enabled to make the ramdisk-related changes.
For these changes, I selected the following:
CONFIG_BLK_DEV_INITRD=y
CONFIG_INITRAMFS_SOURCE=""
CONFIG_BLK_DEV_RAM=y
CONFIG_BLK_DEV_RAM_COUNT=16
CONFIG_BLK_DEV_RAM_SIZE=4096

For the "Target Image Generation" option, I choose the target image as "ext2.gz ramdisk" and "create a ramdisk or initramfs image that can be used by u-boot".

As a result of the build (I worked around the invalid "-a m68knommu" passed to mkimage with "-a m68k"), I got the following files:

-rw-rw-r--  1 builder builder 27177396 Nov  5 04:54 rootfs.ext2.gz
-rw-rw-r--  1 builder builder 27177460 Nov  5 04:54 rootfs.ext2.gz.uboot
lrwxrwxrwx  1 builder builder       22 Nov  5 04:54 rootfs_image -> ./rootfs.ext2.gz.uboot
...
-rw-r--r--  1 builder builder  1265576 Nov  5 04:54 uImage

Then, I tried to boot:
U-Boot 2009.08-00065-g45bb267 (Dec 22 2009 - 17:05:01)

CPU:   Freescale MCF53015 (Mask:76 Version:1)
       CPU CLK 240 MHz BUS CLK 80 MHz
Board: Freescale M53017EVB
I2C:   ready
DRAM:  64 MB
FLASH: 16 MB
In:    serial
Out:   serial
Err:   serial
Net:   FEC0, FEC1
-> tftp 41000000 psl/uImage
...
-> tftp 42000000 psl/rootfs_image
...
-> setenv bootargs root=/dev/ram rw ramdisk_size=57380 panic=10
-> bootm 41000000 42000000
## Booting kernel from Legacy Image at 41000000 ...
   Image Name:  
   Created:      2010-11-05  11:54:41 UTC
   Image Type:   M68K Linux Kernel Image (gzip compressed)
   Data Size:    1265512 Bytes =  1.2 MB
   Load Address: 40020000
   Entry Point:  40020000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 42000000 ...
   Image Name:   uboot ext2 ramdisk rootfs
   Created:      2010-11-05  11:54:40 UTC
   Image Type:   M68K Linux RAMDisk Image (gzip compressed)
   Data Size:    27177396 Bytes = 25.9 MB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
   Loading Ramdisk to 42538000, end 43f231b4 ... OK
Linux version 2.6.29 (emcraft@localhost.localdomain) (gcc version 4.4.1 (Sourcery G++ Lite 4.4-53) ) #7 Fri Nov 5 04:54:24 PDT 2010
...
NET: Registered protocol family 17
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
List of all partitions:
No filesystem could mount root, tried:  ext3 ext2 minix vfat msdos iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
Rebooting in 10 seconds..


What I did wrong? Is it ever possible to boot the board with uImage +
u-boot ramdisk?

There is an option in the target system image configuration to create
the "initramfs" target image, which produces initramfs.cpio.gz.uboot
image.

What kernel option should I enable to boot this type of target filesystem image with kernel uImage?
What U-Boot bootargs should I set to do this?

Thanks for any help.

Regards,
Sergei


Outcomes