AnsweredAssumed Answered

DNS not working!

Question asked by Joe Nicholson on Sep 27, 2010
Latest reply on Aug 26, 2011 by Blake Leverett

Hi

 

I can't seem to get DNS functionality to work!!

 

I've tried building the secure email demo program, which has DNS for the time server lookup, but it fails to resolve DNS, giving the error 'Failed - address not resolved'.

 

I've set RTCSCFG_ENABLE_LWDNS 1 in user_config.h and rebuilt MQX.

 

I'm sure about the DNS address (192.168.1.1) and have set up a PC on the network to have a static IP and this DNS successfully.

 

MQX networking is otherwise working, I can telnet in to web_hvac, for instance.

 

I've tried coding it myself too, using the RTCS user guide for reference: still dead.

 

I'm using MQX 3.6 and the TWRMCF52259.

 

Any idea what I might be doing wrong? I'd like to get the heads-up of the security email demo working to the point that it can resolve the time server, if possible. Does it actually work for anyone else?  Anyone fancy doing a quick test?

 

Thanks in advance!

 

Joe

 

Outcomes