Emanuele Ziglioli

CW10 error building EWL_C project

Discussion created by Emanuele Ziglioli on Aug 9, 2010
Latest reply on Sep 1, 2010 by Processor Expert

Hello everyone,

 

I'm testing CW 10 Coldfire. I need to build the EWL_C project for Coldfire with our specific settings.

I've imported the project into my CW 10 workspace as "Existing projects" from the import wizard.

I've left the "Copy projects into workspace" tick box unchecked.

 

When I try to rebuild the project I get this error:

 

 

(Cannot run program "make": The directory name is invalid.
)

 

 

 

 

Under Project Settings/C/C++ Build/Builder Settings I see:

 

(don't use default build command)

Build command: make -f EWL_C.mak CWINSTALL=${PA_TOOLS_HOME}

 

Build directory: ${workspace_loc:/EWL_C.project}

 

The project is on my hard driver under: C:\Program Files (x86)\Freescale\CW MCU v10.0\MCU\ColdFire_Support\ewl\EWL_C

 

I've tried changing the path before "make" but with no result, the same error.

The "EWL C Reference.pdf" guide is no help since it still talks about "mcp" projects.

 

Any suggestion? Thanks!

Emanuele

Outcomes