mukund jampala

JTAG Clock Speed Error

Discussion created by mukund jampala on Aug 3, 2010
Latest reply on Aug 4, 2010 by Ronald Collins

Hi Guys,

 

I am trying to get hold of the P1020 (I guess it is a QorIQP2 processor).

I have got a code warrior v8.8 from freescale in a DVD. I installed it on my Windows XP 32-bit Machine.

Follwed by it, codewarrior updater suggested be a bunch updates for 8.8.3 and othe P1020/P1021/P2020/ 8572 so forth.

I have installed all the updates suggested.

 

Followed by i also installed the RHOS update for USBTAP.

(http://www.freescale.com/webapp/sps/site/overview.jsp?nodeId=012726006178821410)

 

I created a basic hello_world application.

Connected USBTAP as the manual. The driver shows up in windows driver manager.

But when try to debug BUTTON, it complains "JTAG Clock Speed Error".

Attached are the Image files of codewarrior JTAG errors when trying to debug the test application

 

I also tried running the server commands "show cc" and it shows as if I am connecting a Parrallel CC not the USBTAP.

I tried configring with commands like

    config cc utap:<SER_NUM>

Had no luck.

 

Is there a smart if finding out if the USBTAP is set right?

Outcomes