sunil khatri

unable  to burn u-boot image into the flash using code warrior

Discussion created by sunil khatri on Jun 10, 2010
Latest reply on Jun 14, 2010 by Ronald Collins

1.we are having a new board based on mpc8640

2.we need to have a config file as initialisation file required by code warrior. so we took help from available hpcn board cfg file and wrote our own.

3.it helped and board registers are initialised.

4.but now when we tried harware diagnosis tool adn tried to put our u-boot.bin into flash it starts downloading flash dirver but failed and error message was sth like clobbered ddr. failed to access DDR memory because unable to get magic no from the device.check ur device type or its configuration setting .

5.we tried all possible different setting for ram but not able to get the flash driver downloaded in ddr to burn u-boot into flash..

6.we have 512 MB of ram MT47H64M16 – 8 Meg x 16 x 8 banks.

please sombody help me in getting away from this error.

if this problem is because of DDR initialisation setting please tell me the setting values in ddr ram controller we are using controller 2 type of ram ddr2 and capacity 512 MB. four chips each of 128 Mb each with setting as 13 rows 10 colums and 3 logical banks.

 

if u need any more details for help please u are welcome.please our full project is hanging around for a start after board bring up. i an attaching the config fiel from our board..

 

thanks sunil khatri 

realtime techsolutions.

Outcomes