Pierre Grondin

CodeWarrior 10 Eclipse Linux : Getting USB P&E Multilink drivers to work (HCS08)

Discussion created by Pierre Grondin on Apr 16, 2010
Latest reply on Nov 8, 2012 by John Cottier

I am looking to find a way to get the USB P&E Multilink drivers working with CodeWarrior 10 for Linux


I looked for some procedures on the beta site but did not find anything. I saw that RedHat Enterprice 5.2 is supported somewhere in the CW10 documentation but I guess the real answer is that CW is not that limited regarding Linux distribution.


I tried with Ubuntu 9.10 x64 and Ubuntu 9.10 x86 without success. In both cases CW10 ran fine but when I tried to debug the code with the P&E Multilink for a HCS08, the Multilink is not found (GDI not found error)


Looking at the installation, there is a P&E folder is /usr/local so I tried to recompile et reinstall the driver but it did not work. On x64, it simply does not compile while on x86, it compiles but does not install complaining about a missing usbfs.


I am willing to switch Linux distribution if needed.


Thanks for the help.