AnsweredAssumed Answered

MC9RS08KA2 full-chip simulator --- attempt to use unimplemented memory

Question asked by Carl Lewis on Nov 9, 2009
Latest reply on Nov 19, 2009 by Carl Lewis

Hi,

 

Just got a USBSpyder08 kit, which includes a copy of codewarrior. I'll be targetting the MC9RS08KA2. The hardware hasn't arrived yet, but I noticed that CW includes a full-chip simulator for the RS08. So I ran through the device initialization wizard, ran the simulator, and it immediately fails with the error message "attempt to use unimplemented memory".This seems to happen whenever the simulator encounters an instruction that uses the paging window to access the high page registers. Any advice? Am I missing something? I tried loading up the RS08 demo shipped with Codewarrior and targetting the simulator with that too, and it fails with the same error. Datasheet confirms that the memory address is a real register, and oddly enough the "View register files" menu command even lists the register with the right address.This is my first exposure to CodeWarrior, up until now I've been working with PICs, so perhaps I'm missing something obvious.

 

Cheers,

Carl

Outcomes