AnsweredAssumed Answered

CCS says that it "can't open USB"

Question asked by Ken Macfarlane on Oct 28, 2009
Latest reply on Oct 30, 2009 by Ken Macfarlane

Codewarrior Connection Server (CCS) is giving me grief again, having worked for months without incident: any ideas anybody about how to get it to let Codewarrior drive my USBTaps again? It'll debug ok with MacGraigor Wigglers on the LPT port, so the JTAG port on the target works, and I've got the JTAG clock speed set to a conservative 500kHz.

 

Some Details:

 

FlashProgrammer is similarly affected. Its error message implies that the USB isn't powered up.

The Tx/Rx led on the USBTap blinks every few seconds, though the Run/Pause does nothing.   

Tried 2 USBTaps, and 2 PC's, and neither PC can talk to either USBTap, though they did last time that I used them, some weeks ago (the PC's are shared with other software developers).

Tried upgrading my CW from 8.2 to 8.2.3 

 

USBView can see the USBTaps, and the FlexLm dongle is a USB device, so its highly unlikely that the USB port is electrically broken.

 

I've never like the way that the remote debugger panel in CW fights with CCS regarding which port the debugger is on: you have to close Codewarrior, and and then let CCS read the all important "config cc utap" line from its ccs.cfg file, which is what actually sets which debugger physical interface is in use.

 

All suggestions gratefully received!

 

Ken M

Outcomes