AnsweredAssumed Answered

CW Lite w/M52259DEMO board, cannot erase/program NEW projects (demos work) all set for OSBDM

Question asked by Pierre Mauboussin on Oct 14, 2009
Latest reply on Jun 2, 2010 by Corradi Fulvio

OS is WinXP SP3

CW v7.1.2

Board: M52259DEMO

 

Every time I try to create my own project (with or without MQX) and I then try to erase or flash the memory, CW has a seg fault and I have to select abort to kill it:

 

 

---------------------------
CodeWarrior Error
---------------------------
CodeWarrior encountered an unhandled exception 0xc0000005 at address 0x1001e78f
(The memory at address 0x00000000 could not be read)

Location: IDE_MSL_DLL90_x86.dll:0x1001e78f

Crash dump written to C:\Program Files\Freescale\CodeWarrior for ColdFire V7.1\bin\IDE.exe.b3024.20091013.213433A.dump

Choose 'Abort' to end the program, 'Retry' to debug, or 'Ignore' to continue (at your own risk!)
---------------------------
Abort   Retry   Ignore  
---------------------------

 

The erase log  shows some calls to the GDI API and when it tries the first memory read, it croaks.

 

I have spent a long time comparing the set-up files for the MQX web hvac demo and my new project, and (except for the path info) the info seems identical.  The web hvac projects erases & programs fine.  I have also tried non-MQX projects and have the same error.

 

My projects & the demos are all set to use the OSBDM USB debugger.

 

There may be a path problem finding the right m52259demo.cfg file, but I can't see the error.  I've tried switching the paths between project relative/absolute/MQX_PATH and all that did was trash the project file (the IDE showed multiple entries afterwards which I was unable to correct).

 

Anyone else have this problem and found a solution?

 


Thanks

Outcomes