Antonio Quevedo

Codewarrior does not let me load program into a DEMO9S08LC60 board

Discussion created by Antonio Quevedo on Oct 6, 2009
Latest reply on Oct 8, 2009 by kef

I hope someone can help me with this.

 

I tried to load a program into my DEMO9S08LC60 board, and while transferring the code, the CodeWarrior locked up. I had to restart my machine (Windows XP). When I tried to load again using the "True-Time Simulator & Real-Time Debugger" again, I got the following messages, in sequence:

 

-  Warning: Loading a new application will stop the execution of the current one (2 options: OK and Cancel, I chose OK)

- Error: While in RUN mode, the emulator can only execute the STOP and RESET commands (1 option: OK)

- Error: Failed to load "...(project path)\bin\Project.abs", Error: failed to set program counter for this ELF file (1 option: OK)

 

And that's it, nothing loaded.

 

I tried to reinstall CodeWarrior , and the errors continue showing up. Is there a problem with garbage loaded in the Flash memory of my microcontroller? If so, how can I restore it to normal function?

 

Thanks in advance

Outcomes